XL 2019 RechercheV partielle ne fonctionne que pour une partie de mon tableau

Chahid77

XLDnaute Nouveau
Bonjour à tout le monde,

Je vais essayer d'expliquer mon problème clairement. J'ai un fichier, IDEEAMTBUR1, comprenant 2 feuilles, feuille1, feuille1, feuille2.

On s'intéresse ici aux deux dernières feuilles. Dans la feuille 1, colonne B, j'effectue une RECHERCHEV PARTIELLE, afin de trouver la donnée de la colonne A dans la colonne A de la feuille 2, vous me suivez ? Tout fonctionne très bien jusqu'à la 2100 énième lignes. En effet, des données de la colonne A feuille1 sont comprises dans la colonne A feuille2 mais j'ai "N/A". Par exemple, si on filtre colonne A feuille1, en choisissant 416-0201-11, colonne B il y a "N/A" alors que si l'on regarde colonne A feuille2 en filtrant de la même manière on voit que cette donnée est comprise dans une cellule comprenant une multitude de données, alors pourquoi on me la renvoi pas ?

Je galère depuis plusieurs jours à comprendre, rien à faire...
 

Fichiers joints

D.D.

XLDnaute Occasionnel
Bonjour

Première chose que je vois:
=RECHERCHEV("*"&A2&"*";'C:\Users\chahid.nubeebokus\Desktop\[IDEEAMTBUR.xlsx]Feuil5'!A2:A3720;1;FAUX)
Tu limites la recherche aux 3720 premières lignes de Feuil5.

Mets plutôt A:A pour prendre toute la colonne.

(Edit: Ah non, même pas... tu n'as pas "fixer" ton champs, on voit que la formule se décale à chaque ligne.)
 

Chahid77

XLDnaute Nouveau
Bonjour,

Merci de ta réponse ! Effectivement, cela ne fonctionne pas, comme tu as dit, je n'ai pas fixer mon champs...
 

D.D.

XLDnaute Occasionnel
Pour reprendre ton exemple:
416-0201-11 a comme formule
=RECHERCHEV("*"&A5214&"*";'C:\Users\chahid.nubeebokus\Desktop\[IDEEAMTBUR.xlsx]Feuil5'!A5214:A8932;1;FAUX)
mais 416-0201-11
est en ligne 982 de feuille 2 → il n'est plus dans le champs de recherche.

Cependant il y a un autre problème: la cellule contenant 416-0201-11 est trop importante et dans tous les cas la recherchev ne s'effectue pas.
 

Chahid77

XLDnaute Nouveau
Effectivement j'avais pas fait attention au fait que mon exemple n'est plus dans le champs de recherche.

As-tu une alternative pour contrer le fait que la cellule est trop importante ?
 

D.D.

XLDnaute Occasionnel
La limitation est à 256 caractères.
Cependant la formule
=INDEX(Feuil2!A:A;EQUIV(VRAI;INDEX(ESTNUM(CHERCHE(A2;Feuil2!A:A));0);0))
fonctionne correctement :)

Mais.... Whaou, le temps de calcul s'emballe !!
un peu de VBA serait peut être meilleur.
 

Chahid77

XLDnaute Nouveau
Je te remercie une nouvelle fois ! Serait-il possible que tu postes le fichier avec la formule ou bien il est trop volumineux ? J'ai appliqué ta formule et elle ne fonctionne pas...

Concernant le VBA j'ai que des bases très minimes...
 

Chahid77

XLDnaute Nouveau
MAGNIFIQUE ! Tout fonctionne parfaitement, je te remercie pour ton aide !
Pour le temps de calcul, je vais faire avec sauf si tu as une solution rapide en VBA :)
Encore merci !
 

Chahid77

XLDnaute Nouveau
Encore moi !
Même fichier, même recherche mais pour une autre colonne. Je souhaite renvoyer la colonne FAMILY en page2. J'ai appliqué la fonction INDEX mais elle me renvoie #N/A en première ligne
 

Fichiers joints

D.D.

XLDnaute Occasionnel
Mets en C4
=INDEX(Feuil2!$B$3:$B$3721;EQUIV(VRAI;INDEX(ESTNUM(CHERCHE(A4;Feuil2!$A$3:$A$3721));0);0))
 

Chahid77

XLDnaute Nouveau
Je recherche pas A4 cette fois-ci mais B4 mais quand je tape ta formule toujours rien, toujours #N/A qui s'affiche o_O
 

Chahid77

XLDnaute Nouveau
Hello, tu as une solution pour moi ? A partir de la ligne 2351, ma fonction index/equiv ne fonctionne plus, je sais pas pourquoi... Je te joins le fichier!
 

Fichiers joints

D.D.

XLDnaute Occasionnel
Bonjour
pour la même raison que précédemment: la recherche se fait sur des cellules qui ont plus de 256 caractères.
D'ou mon message #13
 

Discussions similaires


Haut Bas