Rechercher valeur supèrieur avec la fonction EQUIV

Pierre42

XLDnaute Nouveau
Bonjour,

Je souhaite utiliser la fonction Equiv pour chercher le numéro de ligne d'une valeur. Mes valeurs étant des pourcentages ils ne sont pas entiers, je souhaiterai donc avoir le numéro de ligne de la valeur supérieure. Mes valeurs sont classées par ordre croissant dans la colonne "D".

J'utilise donc la formule suivante qui fonctionne très bien :
Code:
Equiv (0,25;D2:D10;1)
. Seulement comme le renseigne le type "1", la fonction va me chercher la première valeur infèrieur à 0,25 et non supérieur comme souhaité. Si je met un type "-1", mes valeurs étant en ordre croissant, excel me renvoi un #N/A.

Il y a t il un moyen de contourner la contrainte de cet ordre croissant et de pouvoir trouver mon numéro de ligne où la valeur est supérieur à 0,25?

Je ne souhaite pas utiliser la fonction recherchev puisque j'associe Equiv avec la fonction index pour me permettre de récupérer une Valeur situé dans la colonne A.

Merci
 

Modeste geedee

XLDnaute Barbatruc
Re : Rechercher valeur supèrieur avec la fonction EQUIV

Bonsour®

Seulement comme le renseigne le type "1", la fonction va me chercher la première valeur infèrieur à 0,25 et non supérieur comme souhaité.
:cool:

Equiv(0,25;D2:D10;1)+1
 

R@chid

XLDnaute Barbatruc
Re : Rechercher valeur supèrieur avec la fonction EQUIV

Bonsoir Pierre42,
Bonsoir Modeste geedee,
Du fait que les valeurs sont triées par ordre croissant, on peut le faire aussi avec,
Code:
=NB.SI(D2:D10;"<=0,25")+1
car la formule de Modeste geedee renvoie la valeur d'erreur #N/A quand les valeurs sont toutes supérieures @ 0.25...
voir PJ
Amicalement
 

Fichiers joints

Modeste geedee

XLDnaute Barbatruc
Re : Rechercher valeur supèrieur avec la fonction EQUIV

Bonsour®
car la formule de Modeste geedee renvoie la valeur d'erreur #N/A quand les valeurs sont toutes supérieures @ 0.25...
:cool:
Comme dans tout domaine de recherche !!!
alors, il faut borner l'échantillon ...
(validation de données, plage de recherche, adéquation restitution(ligne,index,valeur))
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas