XL 2016 RECHERCHER UNE VALEUR DANS UN CHAMPS SOUS CONDITIONS

Guillaumeg3

XLDnaute Junior
Bonjour à tous,

Je bloque sur une formule pour rechercher une valeur précise dans un champs.
C'est difficile à expliquer mais je mets le fichier excel exemple.

Dedans j'ai une colonne marque avec plusieurs Marques ici de de voiture différentes
Devant certaines marque j'ai une nationalité mais dans une autre c'est vide ou j'ai un code erreur #REF!

Je voudrais que la formule cherche uniquement la nationalité et sauté celle qui sont vides ou avec le code erreur mais uniquement sur les champs où le nombre d'occurence de la marque est supérieur à 1.

Merci beaucoup de votre aide
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

Un exemple avec une colonne supplémentaire masquée sous forme tableau.
Un recap avec recherche des marques et la nationnalité.
Tu peux aussi faire un filtre et décocher "#REF"

JHA
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

Un essai sans colonne sup
Code:
=SIERREUR(INDEX($B$2:$B$40;PETITE.VALEUR(SI(NON(ESTERREUR($B$2:$B$40))*(ESTTEXTE($B$2:$B$40))*($A$2:$A$40=$E2);LIGNE($A$2:$A$40)-1);1));"")
Edit: On peut raccourcir
Code:
=SIERREUR(INDEX($B$2:$B$40;PETITE.VALEUR(SI((ESTTEXTE($B$2:$B$40))*($A$2:$A$40=$E2);LIGNE($A$2:$A$40)-1);1));"")
JHA
 

Fichiers joints

Dernière édition:

Guillaumeg3

XLDnaute Junior
MERCI Infiniment JHA!

Autant la première version faisait planter mon pc sur mon fichier de 1200 lignes autant la dernière formule a marché impeccablement!

Merci encore à toi
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas