XL 2016 Rechercher des valeurs qui apparaissent plusieurs fois pour des nom différents

persohk

XLDnaute Nouveau
Bonjour,
Je cale. Mon titre n'est pas clair, alors voilà :
Voici mon problème :
J’ai 7 postes de travail (A1, A2,…, A7) qui interviennent auprès de différentes personnes (plus de 100 chacun).
J’ai donc un tableau dans ma feuille 1 avec
Colonne A : Le nom du client
Colonne B : Le poste qui s’occupe du client
J’utilise aussi d’autres colonnes pour d’autres informations.

J’aimerai dans une feuille 2 créer la fiche des contacts client pour chaque salarié, comme suit :
En A1 j’indique le nom du poste et j’aimerai, qu’automatiquement, tous les contacts apparaissent dans un tableau.
De A3 à B103, un tableau avec en colonne A le nom du client et en colonne B des commentaires
En A3, j'ai essayé un tas de formule (recherchev,...), mais en tirant il m’indique toujours le même résultat à savoir le premier client du poste demandé…
J’aimerai qui passe à la deuxième occurrence, puis la troisième, mais je n’y arrive pas
Quelle formule ? Merci de votre aide.
 

Fichiers joints

D.D.

XLDnaute Occasionnel
Hello,

Essaye
=SI(LIGNES(Feuil1!$1:1)<=NB.SI(Feuil1!B:B;Feuil2!$A$1);INDEX(Feuil1!A:A;PETITE.VALEUR(SI(Feuil1!B:B=Feuil2!$A$1;LIGNE(INDIRECT("1:"&LIGNES(Feuil1!B:B))));LIGNES(Feuil1!$1:1)));"")
à valider avec Ctrl + Shift + Entrée
 

JBARBE

XLDnaute Barbatruc
Bonjour à tous,
désolé pas compris !
Voir D.D
Bonne journée!
 
Dernière édition:

persohk

XLDnaute Nouveau
Hello,

Essaye
=SI(LIGNES(Feuil1!$1:1)<=NB.SI(Feuil1!B:B;Feuil2!$A$1);INDEX(Feuil1!A:A;PETITE.VALEUR(SI(Feuil1!B:B=Feuil2!$A$1;LIGNE(INDIRECT("1:"&LIGNES(Feuil1!B:B))));LIGNES(Feuil1!$1:1)));"")
à valider avec Ctrl + Shift + Entrée
Les formules ne veulent pas fonctionner :-( , indique que formules fausses
 

persohk

XLDnaute Nouveau
Chez moi, ca fonctionne.
Ok, merci beaucoup, c'est super ! Et j'ai compris le principe !
Peux-tu encore m'aider ?
Parfois c'est A1 / A2 qui vont s'occuper d'un client X... du coup quand je fait la liste des client de A1 ou A2, client X ne va pas apparaître ..
peut faire la même formule avec l'indication "si contient une parti de la case A1 de la feuil1.
Merci beaucoup
 

D.D.

XLDnaute Occasionnel
Bonjour

Je viens de regarder. J'ai simplement mis Martin dans les deux premières lignes, donc il est vu par les salariés A1 et A2 maintenant.
Et il est extrait dans les 2 cas de sélection.
Je ne comprends donc pas ta remarque.
 

Fichiers joints

mdo100

XLDnaute Occasionnel
Ok, merci beaucoup, c'est super ! Et j'ai compris le principe !
Peux-tu encore m'aider ?
Parfois c'est A1 / A2 qui vont s'occuper d'un client X... du coup quand je fait la liste des client de A1 ou A2, client X ne va pas apparaître ..
peut faire la même formule avec l'indication "si contient une parti de la case A1 de la feuil1.
Merci beaucoup
Bonjour à toutes et tous,

@persohk,
A tester dans le fichier joint:
J'ai aussi ajouté une feuille "Référents Sans Doublons" qui peut-être masquée.

Cordialement.
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas