Microsoft 365 RECHERCHE X sur plusieurs fichiers

gregoryapi

XLDnaute Nouveau
Bonjour à tous et merci d'avance

Je souhaite faire une recherche X sur 2 tableaux différents mais la fonction ci dessous marche individuellement mais pas quand je l'ai regroupe
=RECHERCHEX(P3;Devis!$A$14:$A$400;Devis!$F$14:$F$400):RECHERCHEX(P3;'[Suivi devis 2021.xlsx]Suivi devis'!$A$14:$A$400;'[Suivi devis 2021.xlsx]Suivi devis'!$F$14:$F$400)

Merci pour la correction de votre part
 

Etoto

XLDnaute Accro
Bonjour à tous et merci d'avance

Je souhaite faire une recherche X sur 2 tableaux différents mais la fonction ci dessous marche individuellement mais pas quand je l'ai regroupe
=RECHERCHEX(P3;Devis!$A$14:$A$400;Devis!$F$14:$F$400):RECHERCHEX(P3;'[Suivi devis 2021.xlsx]Suivi devis'!$A$14:$A$400;'[Suivi devis 2021.xlsx]Suivi devis'!$F$14:$F$400)

Merci pour la correction de votre part
Hello,

Si tu veux avoir les résultats des deux RECHERCHEX fusionnés, il faut pas un ":" mais un "&".

A+
 

gregoryapi

XLDnaute Nouveau
Hello,

Si tu veux avoir les résultats des deux RECHERCHEX fusionnés, il faut pas un ":" mais un "&".

A+
Merci pour ta réponse j'ai bien fait
=RECHERCHEX(P3;Devis!$A$14:$A$399;Devis!$F$14:$F$399)&RECHERCHEX(P3;'[Suivi devis 2021.xlsx]Suivi devis'!$A$14:$A$408;'[Suivi devis 2021.xlsx]Suivi devis'!$F$14:$F$408)

Mais excel me revoie #N/A alors que les 2 séparés fonctionnent et que la valeur P3 n'apparait que dans un seul tableau et une seule fois ?
 

Etoto

XLDnaute Accro
Merci pour ta réponse j'ai bien fait
=RECHERCHEX(P3;Devis!$A$14:$A$399;Devis!$F$14:$F$399)&RECHERCHEX(P3;'[Suivi devis 2021.xlsx]Suivi devis'!$A$14:$A$408;'[Suivi devis 2021.xlsx]Suivi devis'!$F$14:$F$408)

Mais excel me revoie #N/A alors que les 2 séparés fonctionnent et que la valeur P3 n'apparait que dans un seul tableau et une seule fois ?
Et.... Le premier RECHERCHEX et le deuxièmes doivent renvoyer quoi comme valeur ?
 

gregoryapi

XLDnaute Nouveau

Etoto

XLDnaute Accro
Merci pour ton aide il m'a suffit de completer la case valeur si non trouve

=RECHERCHEX(P21;Devis!$A$14:$A$399;Devis!$F$14:$F$399;"")&RECHERCHEX(P21;'https://apitreck-my.sharepoint.com/personal/gregory_levo_apimetrology_com/Documents/[Suivi devis 2021.xlsx]Suivi devis'!$A$14:$A$408;'https://apitreck-my.sharepoint.com/personal/gregory_levo_apimetrology_com/Documents/[Suivi devis 2021.xlsx]Suivi devis'!$F$14:$F$408;"")
M
Super, si c'est résolu, oublie pas de marquer la solution.
 

Discussions similaires

Réponses
22
Affichages
2 K

Statistiques des forums

Discussions
294 442
Messages
1 938 528
Membres
188 905
dernier inscrit
esseddyqy2