Autres Recherche V plusieurs critères - excel 2007

Sarah_Bertrand

XLDnaute Nouveau
Bonjour à tous,

J'ai lu beaucoup de choses sur les formules matricielles type index et equiv, mais je ne parviens pas à l'appliquer sur un principe de plusieurs valeurs recherchées.
Dans le fichier ci joint (onglet planification) vous verrez en F9 un début de ligne dans laquelle je souhaites automatiser la valeur de chiffre d'affaire à la semaine (onglet CA semaine) mais qu'elle soit renseignée selon le magasin choisi en B8.

Est ce possible ?

En vous remerciant,
 

Pièces jointes

  • Planification V3.xlsx
    187.2 KB · Affichages: 8
Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

Sommeprod devrait le faire

VB:
=SOMMEPROD((Tableau2[Magasin]=Planification!$B$8)*(Tableau2[Semaines]=Planification!F$10);Tableau2[CA TTC 2019])

JHA
 

Pièces jointes

  • Planification V3.xlsx
    184 KB · Affichages: 2

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je pense que sommeprod ne te donne pas de bon résultat car tu as certainement des différences dans les listes (voir les listes du fichier "'[Planification annuelle V2.xlsx]Effectifs'!$A$1:$F$2344")

JHA
 

Pièces jointes

  • Planification V3 rev1.xlsx
    186 KB · Affichages: 2

job75

XLDnaute Barbatruc
Bonsoir Sarah_Bertrand, JHA, merinos,

Oui pour qu'il y ait le maximum de magasins en commun dans les 2 dernières feuilles il faut :

- remplacer les tirets par des espaces dans la feuille "CA semaine"

- supprimer les espaces superflus dans la feuille "Magasins".

D'où cette formule en F9 de la 1ère feuille, à tirer vers la droite :
Code:
=SOMMEPROD((SUBSTITUE('CA semaine'!$A2:$A2289;"-";" ")=SUPPRESPACE($B8))*('CA semaine'!$B2:$B2289=F10);'CA semaine'!$C2:$C2289)
A+
 

Pièces jointes

  • Planification(1).xlsx
    158.6 KB · Affichages: 1

Sarah_Bertrand

XLDnaute Nouveau
Bonsoir Sarah_Bertrand, JHA, merinos,

Oui pour qu'il y ait le maximum de magasins en commun dans les 2 dernières feuilles il faut :

- remplacer les tirets par des espaces dans la feuille "CA semaine"

- supprimer les espaces superflus dans la feuille "Magasins".

D'où cette formule en F9 de la 1ère feuille, à tirer vers la droite :
Code:
=SOMMEPROD((SUBSTITUE('CA semaine'!$A2:$A2289;"-";" ")=SUPPRESPACE($B8))*('CA semaine'!$B2:$B2289=F10);'CA semaine'!$C2:$C2289)
A+
Merci à tous !
 
Haut Bas