Office 365 Recherche formule

blancolie

XLDnaute Junior
Bonjour,
Je sais qu'on peut utiliser l'outil T.C.D mais je par formule. je réalise un planning. ds mon classeur excel, j'ai un onglet Aperçu (planning) et un autre onglet Bdd( base de donnée ) . ds l'onglet Bdd c 'est la que je rentres toutes mes informations ( agent, date etc). et cela se met automatiquement ds le planning (onglet apercu ). Avec cette formule la : INDEX(Bdd!C4;SI(Bdd!D$4=Apercu!C$3;0)) si ds BDD j'ai 3 djakary avec 3 dates , ds le planning(Aperçu ) si je rentre cette formule ds la premiere ligne tout marche bien, le nom apparait, les dates se mettent à la place prévu mais quand je fais un copie coller ds les cellules en dessous cela me recopie bêtement les agents qui sont indiqués ds le Tableau Bdd , je ce que je recherche c'est quand on se trouve ds Aperçu , je veux voir qu''1 djakary et Bien sur les 3 dates qui lui sont attribue. j'espere avoir été clair, je vous joint mon fichier, vous allez mieux comprendre.

j'espère que vous pourrez m'aidez. en vous remerciant d'avance
 

Fichiers joints

JHA

XLDnaute Barbatruc
Bonjour à tous,

Formule matricielle à essayer en "B8":
VB:
=SIERREUR(INDEX(Tableau1[Nom];EQUIV(0;INDEX(NB.SI($B$7:$B7;Tableau1[Nom]););0));"")
copier vers le bas après validation par les 3 touches Ctrl+Maj+Entrée

JHA
 

Fichiers joints

blancolie

XLDnaute Junior
merci JHA de l'aide apportés mais j'aimerais rajouter des conditions. cela marche tres bien cette formule mais j'aimerais voir apparaitre dans le planning pour le mois d'août que les gens pour ce moiis etc etc. et si dans la colonne agent onglet apercu , si les cellules sont vides j'aimerais que ds le planning , les dates n'apparaissent pas du tout . merci JHA pour ton aide et la futur si cela est dans tes cordes
 

Fichiers joints

Discussions similaires


Haut Bas