XL 2016 Recherche en fonction de 2 critères : 1 code & 1 date

olboaz

XLDnaute Nouveau
Bonjour à tou(te)s,
j'ai besoin d'aide pour résoudre un pb de recherche approchante.
Dans le fichier joint, j'ai des "clients" qui doivent être rattachés à un "groupe" en fonction de dates d'entrée/dates de sortie du "groupe".
En utilisant la fonction recherchev et la valeur proche VRAI, cela ne fonctionne pas dans 1 cas.
Je ne trouve pas la solution, si quelqu'un peut m'aider ?
Merci d'avance
 

Fichiers joints

Dim.Reichart

XLDnaute Occasionnel
Bonjour,
Je ne comprend pas ce que vous cherchez à obtenir comme resultat, mais:
La formule =RECHERCHEV(H3&DATE(I3;J3;1);$A$3:$C$6;3;1) demande de rechercher le numéro client suivi de la date 01/mm/jj format texte dans la même cellule.
En clair, vous demandez a Excel de chercher une date au dela des années 2250, ce qui est déjà hasardeux, mais en plus, vous lui demandez une valeur proche, donc il va considerer les valeurs dont les premiers caractères ressemblent le plus à la recherche, ce qui risque effectivement d'occasionner quelques erreurs.

Il manque des informations sur le raisonnement à suivre pour établir une formule correcte.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas