XL 2010 Recherche d'une formule pour déterminer une note en fonction d'un texte en "validation de données".

gui27440

XLDnaute Nouveau
Bonjour à tous,

Je suis à la recherche d'une formule, pour me donner une note en fonction d'un texte en "validation de données" avec une liste.

Ex:
Dans ma cellule S12 je peux choisir entre : Très satisfaisant; Satisfaisant; Insatisfaisant; Très insatisfaisant

Pour Très satisfaisant dans la cellule S12 je souhaite la note de 10 dans la cellule AB12
Pour Satisfaisant dans la cellule S12 je souhaite la note de 8 dans la cellule AB12
Pour Insatisfaisant dans la cellule S12 je souhaite la note de 6 dans la cellule AB12
Pour Très insatisfaisant dans la cellule S12 je souhaite la note de 4 dans la cellule AB12

Pouvez-vous s'il vous plaît m'aider ?

Merci d'avance
 

job75

XLDnaute Barbatruc
Bonjour gui27440,

Une solution avec cette formule :
Code:
=SIERREUR(RECHERCHEV(S12;{"Très satisfaisant".10;"Satisfaisant".8;"Insatisfaisant".6;"Très insatisfaisant".4};2;0);"")
Mais bien sûr la matrice {"Très satisfaisant".10;"Satisfaisant".8;"Insatisfaisant".6;"Très insatisfaisant".4} peut être remplacée par une plage de cellules.

A+
 

gui27440

XLDnaute Nouveau
Bonjour Job75,

Merci beaucoup de ton retour.
Cela fonctionne !

Très bonne journée
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas