recherche données avec un critère à plusieurs valeurs

didousama

XLDnaute Nouveau
Bonjour,

Mon fichier de travail est compose ainsi :
Un onglet chiffrage où on a pour chaque phase d’un projet, les différentes tâches qui seront exécutées, les noms des personnes qui les exécuteront, le nombre d’heures qui leur est attribués, la désignation des frais engendrés avec leurs montants estimés
Un onglet suivi où pour chaque tâche de chaque phase on a un tableau pour chaque personne qui retrouve le nombre d’heures prévisionnel (du chiffrage) et où on saisit un nombre d’heures réel effectué, même tableau pour les frais (coût prévisionnel retrouvé du chiffrage et réel saisi)
Un dernier onglet qui contient juste un tableau liste des différents frais

Mon problème est :
Dans mon onglet de suivi pour retrouvé automatiquement les heures prévisionnelles j’utilise cette formule :
=SOMMEPROD((chiffrage!$C$5:$C$10=suivi!$C$3)*(chiffrage!$B$5:$B$10=suivi!B5);chiffrage!$D$5:$D$10)

Je souhaiterais utiliser le même système pour retrouver la somme des frais engendrés par chaque tâche en utilisant la liste de l’onglet ressource
J’ai bêtement tenté =SOMMEPROD((chiffrage!$E$5:$E$10=ressource!$A$1:$A$5)*(chiffrage!$B$5:$B$10=suivi!B5);chiffrage!$F$5:$F$10)qui me retourne #N/A
Auriez-vous donc une idée pour régler ce problème en sachant que dans mes frais chiffrés apparaissent Machine A et Machine B que je ne veux pas prendre en compte et que si pour la même tâche j’ai deux frais différent dans le suivi doit s’afficher leur somme

Mon explication étant peut-être brouillon je joins un fichier exemple

Je vous remercie d’avance toute personne qui se penchera sur mon problème
 

Fichiers joints

didousama

XLDnaute Nouveau
Re : recherche données avec un critère à plusieurs valeurs

Bonjour et merci pour cette solution qui correspond effectivement à ma demande et fonctionne très bien dans mon fichier test

Le seul bémol c’est que dans mon vrai fichier de travail, le nombre de machines est bien plus conséquent.

Ce qui veut dire que si j’ai 20 machines je devrais mettre 20 (chiffrage!$E$5:$E$10<>"Machine B") dans ma formule.

Et si je dois rajouter des machines plus tard, il faudra que je reprenne toutes mes cases pour mettre à jour la formule, c’est pourquoi je cherchais une solution en utilisant ma liste dans mon onglet ressource.

Mais si cela est effectivement impossible alors je devrais mettre en place cette solution.
 

didousama

XLDnaute Nouveau
Re : recherche données avec un critère à plusieurs valeurs

Merci pour la réponse rapide

Malgré tout cette solution n'irait pas puisque dans mon vrai fichier les machines ont des noms complètements différents les une des autres les termes Machine A et Machine B sont juste des termes simples que j'ai utilisé pour mon fichier test

Pour l'instant je reste donc sur votre solution précédente au cas où une solution automatique par la liste de l'onglet ressource ne serait pas possible
 

AL1976

XLDnaute Junior
Re : recherche données avec un critère à plusieurs valeurs

rebjr,
je crois qu'on est bon ....voir fichier attaché.
cdlmt,
AL
PS: j'ai triché, je me suis faite aider sur un autre forum (anglosaxon) que je suis. hope this helps.
 

Fichiers joints

didousama

XLDnaute Nouveau
Re : recherche données avec un critère à plusieurs valeurs

Bonjour,

Je viens de tester et ça fonctionne nikel.

Merci beaucoup
 
Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas