XL 2010 Recherche correspondance valeur dans plage

etpisculrien

XLDnaute Occasionnel
Bonjour à tous,

J'ai un problème qui semble simple quand on lit le sujet mais plus compliqué qu'il n'y parait...
Je vais essayer d'expliquer mais mon fichier sera plus explicite à mon avis :
Sur ma feuille 1, j'ai en colonne A, une liste de numéros client puis une date de début (col B) et fin d'intervention (col C).
Sur ma feuille 2, j'ai un numéro de client par ligne et un agenda de l'année par colonne.
Je souhaiterais trouver une formule qui me permette de mettre "vrai" sur la feuille 2 lorsque le client et la date du jour correspond au client et à la plage de date sur le feuille1. (le problème étant que le client peut apparaitre sur plusieurs lignes de la feuille 1.
Pour mieux comprendre, j'envoi un exemple du fichier. J'ai trouvé un piste de formule (feuille 2 cellule M3:O3) mais ça n'a rien de dynamique et je ne peux pas recopier ma cellule dans tout mon tableau.
Si un esprit éclairé (contrairement au mien embrumé) pouvait m'aider svp...
Merci d'avance
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonjour etpisculrien,

Formule en C3 de Feuil2, à tirer vers la droite :
Code:
=SOMMEPROD(($A3=Feuil1!$A2:$A6)*(C2>=ENT(Feuil1!$B2:$B6))*(C2<=ENT(Feuil1!$C2:$C6)))
ou :
Code:
=SOMMEPROD(($A3=Feuil1!$A2:$A6)*(C2>=ENT(Feuil1!$B2:$B6))*(C2<=ENT(Feuil1!$C2:$C6)))>0
si l'on veut obtenir VRAI ou FAUX.

A+
 

Discussions similaires


Haut Bas