Recherche correspondance relative dans une colonne

franckdarko

XLDnaute Nouveau
Désolé pour le titre surement peu clair, je n'ai pas trouvé mieux...

Mon problème :
J'ai des données (parfois texte, parfois numérique/texte) dans ma colonne A.
J'aimerai trouver une formule qui me permette de faire ceci :
. Rechercher X (qui sera toujours du texte) dans la colonne A et me ramener :
--> Le contenu de la cellule qui se trouve 3 cellules en dessous de X mais uniquement si elle commence par un caractère numérique, sinon :
--> Le contenu de la cellule qui se trouve 4 cellules en dessous de X.

Merci par avance !

Fichier exemple :
 
Dernière édition:

piga25

XLDnaute Barbatruc
Bonjour franckdarko, le forum

un essai à mettre en C1 :
=SI(ESTNUM(GAUCHE(INDEX(A2:A534;EQUIV($B$2;A2:A534;0)+3;1);1)*1);INDEX(A2:A534;EQUIV($B$2;A2:A534;0)+3;1);INDEX(A2:A534;EQUIV($B$2;A2:A534;0)+4;1))
 

job75

XLDnaute Barbatruc
Bonjour franckdarko, piga25,

Un peu plus simple en C2 :
Code:
=INDEX(A:A;EQUIV(B2;A:A;0)+3+ESTERR(-GAUCHE(INDEX(A:A;EQUIV(B2;A:A;0)+3))))
PS : sur cjoint les fichiers sont supprimés au bout d'un certain temps, pas sur XLD...

A+
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas