XL 2019 rech V un peu avancé

titooooo

XLDnaute Occasionnel
Bonjour le forum

je bloque en une formule de recherche verticale mais un peu élaboré

je dispose de résultat oui , non pour une série de données qui se répètent , exemple équipe A a des rencontre avec équipe b,c,d etc

mais veut que Excel me donne le résultat par ordre et non pas que la première de la liste

c'est a dire veut que toute les ligne sur lequel mon équipe figure que ce soit comme jouant a domicile ou invité et par ordre chronologique

D'avance merci
 

Pièces jointes

  • Tito1.xlsx
    48.9 KB · Affichages: 10

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Titoooo,
En PJ un essai avec une macro Worksheet_Change. Le club se met en I1, le calcul est automatique.
VB:
Sub Worksheet_Change(ByVal Target As Range)
    If Target.Count > 1 Then Exit Sub
    If Not Intersect(Target, [I1]) Is Nothing Then
        Application.ScreenUpdating = False
        Dim DL%, i%, Ligne%, T
        DL = Range("B65500").End(xlUp).Row
        T = Range("B2:D" & DL)
        Range("I2:I" & DL).ClearContents: Ligne = 2
        For i = 1 To UBound(T)
            If T(i, 1) = Target Or T(i, 2) = Target Then
                Cells(Ligne, "I") = T(i, 3)
                Ligne = Ligne + 1
            End If
        Next i
    End If
End Sub
 

Pièces jointes

  • Tito1.xlsm
    54.8 KB · Affichages: 5

job75

XLDnaute Barbatruc
Bonsoir titooooo, sylvanu,

Bien sûr qu'il existe une formule matricielle, en K2 du fichier joint :
VB:
=SIERREUR(INDEX($D:$D;PETITE.VALEUR(SI(($B$2:$B$206=K$1)+($C$2:$C$206=K$1);LIGNE($B$2:$B$206));LIGNE(K1)));"")
A+
 

Pièces jointes

  • Tito1(1).xlsx
    49.4 KB · Affichages: 6

titooooo

XLDnaute Occasionnel
Merci job pour cette formule sympa

J'aurais besoin aussi encore d'un peu d'aide svp

en effet là j'ai qq chose de combiné je cherche partant de même principe avoir les match en Cleansheet ( parfois l'équipe joue a domicile et parfois en extérieur)

Cleansheet c'est a dire équipe termine sans concerder des but donc score de l'autre équipe reste à 0

autre point je veut aussi par le même principe déterminer si l'équipe marque plus de but en première mi temps ou deuxième ou aucun

exemple

résultat mi temps 1-0
résultat match 2-1

donc l'équipe domicile marque 1 chaque mi-temps donc aucune
pour équipe 2 elle marque 1 contre 0 en 1ére mi-temps donc c'est en 2éme mi-temps qu'elle marque plus de but

d'avance 1000 merci
 

Pièces jointes

  • Tito2.xlsx
    56.4 KB · Affichages: 3
Dernière édition:

Dugenou

XLDnaute Barbatruc
Bonjour,
Avec la formule de Job, que je salue, et un petit bricolage
Pour info : le résultat des colonnes F, G et H pourraient être calculés.

Cordialement
PS il y a une deuxieme cleansheet pour Lazio
 

Pièces jointes

  • Tito2.xlsx
    57.4 KB · Affichages: 4