XL 2010 Récap heures par semaine sur onglet différent

Marylgb

XLDnaute Junior
bonjour,

J'aimerai pouvoir faire un récap des heures par semaines par veilleur sur une autre feuille du fichier.
en PJ l'exemple.....
merci d'avance
bonne journée
 

Pièces jointes

  • Planning veilleurs de nuits v 09-06.xlsx
    35.3 KB · Affichages: 2

JHA

XLDnaute Barbatruc
Bonjour à tous,

J'ai de nouveau modifié les formules des onglets "Recap" afin d'éviter les erreurs en fin d'année.
Auparavant le calcul se faisait par rapport au numéro de semaine et de l'année donc il y avait un soucis pour la semaine à cheval entre 2021 et 2022.
Désormais le calcul se fait avec les dates de début et fin de chaque semaine.
VB:
=SOMMEPROD((planning!$A$3:$A$233>=DATEVAL(STXT($B4;4;10)))*(planning!$A$3:$A$233<=DATEVAL(STXT($B4;18;10)))*(planning!O$3:O$233))
La formule est plus facile à comprendre et évite les erreurs citées.

JHA
 

Pièces jointes

  • Planning veilleurs de nuits v 09-06 Rev2.xlsx
    48.2 KB · Affichages: 2

Marylgb

XLDnaute Junior
Bonjour à tous,

J'ai de nouveau modifié les formules des onglets "Recap" afin d'éviter les erreurs en fin d'année.
Auparavant le calcul se faisait par rapport au numéro de semaine et de l'année donc il y avait un soucis pour la semaine à cheval entre 2021 et 2022.
Désormais le calcul se fait avec les dates de début et fin de chaque semaine.
VB:
=SOMMEPROD((planning!$A$3:$A$233>=DATEVAL(STXT($B4;4;10)))*(planning!$A$3:$A$233<=DATEVAL(STXT($B4;18;10)))*(planning!O$3:O$233))
La formule est plus facile à comprendre et évite les erreurs citées.

JHA
bonjour

Super, Trés bien, merci ;-)
bonne journée
 

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
288 632
Messages
1 893 633
Membres
169 984
dernier inscrit
mdemrs
Haut Bas