quelle est la formule ad hoc ?

philouis

XLDnaute Junior
Bonjour le forum,

Qelle formule appliquer, et surtout quelle syntaxe, pour extraire de la colonne D la valeur correspondant qui est comprise dans une plage de valeurs dont le mini (supérieur ou égal) de cette plage est en colonne B et dont le maxi (inférieur ou égal) de cette plage est en colonne C.

Voir exemple ci-dessous.

Le problème est sans doute élémentaire pour vous ... mais insoluble pour moi.

Merci d'avance pour votre réponse.


A B C D E F
REVENU MINI REVENU MAXI QF REVENU REEL

6 26220 ?
7
8
9
10 25000 25999 0,30
11 26000 26499 0,25
12 26500 26599 0,20
13 26600 26999 0,15

EX : en F6, pour un revenu effectif de 26220 (en E6) c'est à dire compris dans la tranche (supérieur ou égal à) 26000 et (inférieur ou égal à) 26499 dans le tableau a10 : b13 le QF appliquable (c10 : c13) sera de 25% , etc.
 

abcd

XLDnaute Barbatruc
Re : quelle est la formule ad hoc ?

Bonjour,

Exemple pas très compréhensible, alors qu'une petite pièce jointe est si facile !

A essayer :
=RECHERCHEV(A6;B10: D13;3)
(sans l'espace entre B10: D13)
A6 contient 26220, la colonne D étant celle des coefficients, la colonne C est inutile.

abcd
 

BrunoM45

XLDnaute Barbatruc
Re : quelle est la formule ad hoc ?

Salut Filouis,

Si j'ai bien compris les références, en E6 tu mets la formule :
=SOMMEPROD((F6>=B10:B13)*(F6<=C10:C13)*(D10: D13))

A+
 

philouis

XLDnaute Junior
Re : quelle est la formule ad hoc ?

Bonsoir ABCD, BRUNOM45 et JEAN PIERRE

Merci pour la rapidité de vos réponses.
La proposition de BRUNO 45 fonctionne parfaitement
Je suis sur que ABCD et JEAN PIERRE me l'auraient également faite si j'avais été plus clair dans ma question.

Merci le forum, vous êtes tous super !

Bonne soirée à tous

Philouis
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas