Microsoft 365 Probleme sur SOMME PROD

trekkeur50

XLDnaute Junior
Bonjour,
Je cherche a faire la somme de la colonne Q de la feuille stock :
- quand la colonne A de la feuille stock est egale a la cellule A941 de la feuille BDD formule.
- et quand la colonne J de la feuille stock est egale a "affilie France" ou "Succursale" ou "GL BHV"
Ma formule ci dessous ne fonctionne pas et je ne sais pas pourquoi
=+SOMMEPROD((Stock!Q:Q)*(Stock!A:A='BDD formule'!A941)*((Stock!J:J="affilie France")+(Stock!J:J="SUCCURSALE")+(Stock!J:J="GL BHV")))

Merci de votre aide
 

trekkeur50

XLDnaute Junior
Bonjour,
Je cherche a faire la somme de la colonne Q de la feuille stock :
- quand la colonne A de la feuille stock est egale a la cellule A941 de la feuille BDD formule.
- et quand la colonne J de la feuille stock est egale a "affilie France" ou "Succursale" ou "GL BHV"
Ma formule ci dessous ne fonctionne pas et je ne sais pas pourquoi
=+SOMMEPROD((Stock!Q:Q)*(Stock!A:A='BDD formule'!A941)*((Stock!J:J="affilie France")+(Stock!J:J="SUCCURSALE")+(Stock!J:J="GL BHV")))

Merci de votre aide

Je complete avec un exemple de fichier.
J ai essaye de delimiter le champ mais sans succes.
Autre probleme, le fichier fait plus de 500 000 lignes et cette formule a l'air d alourdir tres fortement le fichier.Si il y a une autre methode que sommeprod je suis preneur
merci
Je complete avec un exemple de fichier.
J ai essaye de delimiter le champ mais sans succes.
Autre probleme, le fichier fait plus de 500 000 lignes et cette formule a l'air d alourdir tres fortement le fichier.Si il y a une autre methode que sommeprod je suis preneur
merci
 

Pièces jointes

  • Illustration.xlsx
    283.6 KB · Affichages: 9

djidji59430

XLDnaute Barbatruc
Re
Jha t'a bien dit de délimiter les champs.
Or tu mets quoi, comme formule ?
=+SOMMEPROD((Stock!D2:D9)*(Stock!A:A='BDD formule'!A2)*((Stock!C:C="affilie France")+(Stock!C:C="SUCCURSALE")+(Stock!C:C="GL BHV")))
T'appelle ça des champs délimités ?
Là, oui
=+SOMMEPROD((Stock!D2:D9)*(Stock!A2:A9='BDD formule'!A2)*((Stock!C2:C9="affilie France")+(Stock!C2:C9="SUCCURSALE")+(Stock!C2:C9="GL BHV")))
Et ça fonctionne !
Mais c'est vrai que 500000 sommeprod, ça prend du temps !
Pour aller plus vite, il faut le faire en VBA. sans moi


Crdlmt
 

CB60

XLDnaute Barbatruc
Bonjour a tous
Tout d'abord, tu dois mettre ta base sous forme de tableau!
Ensuite la formule sommeprod est:
VB:
=SOMMEPROD((Tableau1[Stock])*(Tableau1[CODE&CO]='BDD formule'!A2)*((Tableau1[Reseau]="affilie France")+(Tableau1[Reseau]="SUCCURSALE")+(Tableau1[Reseau]="GL BHV")))

ou, si seulement eviter les cellules vide de la colonne C

Code:
=SOMMEPROD((Tableau1[Stock])*(Tableau1[CODE&CO]='BDD formule'!A2)*((Tableau1[Reseau]<>"")))
 

Pièces jointes

  • Illustration.xlsx
    283.6 KB · Affichages: 5

Discussions similaires

Réponses
4
Affichages
349

Statistiques des forums

Discussions
294 210
Messages
1 936 893
Membres
188 096
dernier inscrit
Soudeur2.0