XL 2013 Problème sur formule excel

Anthony790501

XLDnaute Nouveau
Bonsoir à tous je n'arrive pas à trouver une formule pour mon fichier "planning".

En effet je souhaiterais trouver une formule qui me remplis automatiquement la cellule "0" ou "IS" ou "IRU" ou "IR".
En sachant que cette formule doit comporter plusieurs conditions :

0 : Si mon repas est compris entre "11:00 et 14:30" ou entre "18:00 et 22:00, que ma pause est prise en "ENT" et qu'elle est >= à 1:00
IS : Si mon repas est compris entre "11:00 et 14:30" ou entre "18:00 et 22:00, que ma pause est prise en "ENT" et qu'elle est >= à 1:00; dont au moins 0:30 est compris entre "11:00" et "14:30" ou entre "18:00" et "22:00"
IRU : Si mon repas est compris entre "11:00 et 14:30" ou entre "18:00 et 22:00, que ma pause est prise en "ENT" et qu'elle est < à 1:00
IR : Si mon repas n'est pas compris entre "11:00 et 14:30" ou entre "18:00 et 22:00, peut importe le lieu ou le temps de pause repas.

Merci de votre aide.

Anthony
 

Pièces jointes

  • Planning 2020 1.xlsx
    24.5 KB · Affichages: 9

Nairolf

XLDnaute Impliqué
Salut Anthony et JHA,

J'ai aussi travaillé sur la question, essayes la formule suivante (à noter que tu n'avais pas identifié un cas (je l'ai annoté "?") :
Code:
=SI(OU(ET(G67*24>=11;G67*24<=14,5);ET(H67*24>=11;H67*24<=14,5);ET(G67*24>=18;G67*24<=22);ET(H67*24>=18;H67*24<=22));SI(I67="ENT";SI(H67-G67<1/24;"IRU";SI(OU(ET(G67*24<11;H67*24-11>=0,5);ET(G67*24<18;H67*24-18>=0,5);ET(H67*24>14,5;14,5-G67*24>=0,5);ET(H67*24>22;22-G67*24>=0,5));"IS";0));"?");"IR")
 

Anthony790501

XLDnaute Nouveau
Bonsoir JHA et Nairof,

Je viens de regarder votre fichier et malheureusement la formule ne fonctionne pas, car quand je mets une heure de repas de 11:00 à 12:00 en ENT, il me met IR alors qu'il devrait me mettre 0. De même quand je mets une heure de repas de 14h00 à 14:45 en ENT, il me met IR alors qu'il devrait me mettre IRU.
Je viens aussi de me rendre compte que quand les cellules heures de repas et lieux de repas sont vides, il me mets "0", alors qu'il devrait mettre "0" si je n'ai pas travaillé ou "IR" si j'ai travaillé. Auriez vous une solution aussi, merci par avance.
Si vous arrivez à trouver d'où viendrait cette erreur ce serait parfait, sinon merci de votre temps et de votre aide.

Anthony LE GLOAN
 

Pièces jointes

  • Planning 2020.xlsx
    26.3 KB · Affichages: 2
Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

quand je mets une heure de repas de 11:00 à 12:00 en ENT, il me met IR alors qu'il devrait me mettre 0.
J'ai ajouté "=" sur la formule "IR"
VB:
=SI(ESTNUM(G67);NON(OU(ET(G67>="11:00"*1;H67<="14:30"*1);ET(G67>="18:00"*1;H67<="22:00"*1)));"")
De même quand je mets une heure de repas de 14h00 à 14:45 en ENT, il me met IR alors qu'il devrait me mettre IRU.
IRU : Si mon repas est compris entre "11:00 et 14:30" ou entre "18:00 et 22:00, que ma pause est prise en "ENT" et qu'elle est < à 1:00
14:45 et supérieur à 14:30 donc pas "IRU"
quand les cellules heures de repas et lieux de repas sont vides, il me mets "0", alors qu'il devrait mettre "0" si je n'ai pas travaillé ou "IR" si j'ai travaillé.
Ajout d'une condition dans la formule.

JHA
 

Pièces jointes

  • Planning 2020 rev1.xlsx
    26.1 KB · Affichages: 1

Anthony790501

XLDnaute Nouveau
Bonsoir JHA,

Merci de votre réponse rapide, je viens de l'ouvrir et en faisant quelques test j'ai pû remarquer des erreurs que j'ai annoté. Pourriez vous essayer d'y remédier car je n'arrive absolument pas à comprendre la formule que vous avez utilisé.

Merci de votre réponse et bonne soirée.

Anthony
 

Pièces jointes

  • Planning 2020 rev1.xlsx
    28.6 KB · Affichages: 1

Statistiques des forums

Discussions
283 682
Messages
1 853 490
Membres
152 183
dernier inscrit
sunzu94
Haut Bas