Problème formule somme

Gasp73

XLDnaute Nouveau
Bonjour à tous,

Voilà mon problème : je souhaite effectuer pour chaque semaine une somme sur une certaine plage de données (dont le nom est variable selon les semaines puisque les données de chaque semaine sont dans une nouvelle feuille de calcul).
Par exemple je souhaite faire "=somme('S1'!A1:A4)" pour la semaine 1, puis "=somme('S2'!A1:A4)" pour la semaine 2 etc.
Ayant trouvé une formule qui me donne le nom de la plage de données automatiquement : ""'S"&B3&"'!"&"$A$1:$A$4", j'aurais aimé pouvoir faire directement =somme('S"&B3&"'!"&"$A$1:$A$4) pour la semaine 1 puis =somme('S"&B4&"'!"&"$A$1:$A$4), mais cela ne marche pas...
Donc si vous avez une formule miracle, ça me sortirais du pétrin !!

J'espère que j'ai bien expliqué mon problème !! (je vous ai joins un fichier excel pour que vous puissiez voir ce que je veux faire)

Merci d'avance !

Gasp73
 

Fichiers joints

Juls

XLDnaute Junior
Re : Problème formule somme

Bonjour,

La formule indirect pourrais surement te convenir : =SOMME(INDIRECT(B4)) par rapport à ton fichier.

Bonne soirée
 

Paf

XLDnaute Barbatruc
Re : Problème formule somme

Bonjour

si dans la feuille Feuil1 , en ligne 3, on avait Semaines S1 S2 S3 S4 ... plutôt que Semaines 1 2 3 4 ...
la formule suivante en B4 ( puis "tirer" vers la droite) fonctionnerait

=SOMME(INDIRECT(B3&"!L6:L44"))

A+

edit ; correction faute de "frappe"
 

Gasp73

XLDnaute Nouveau
Re : Problème formule somme

Bonjour à tous !

Merci pour vos réponses, effectivement cela marche parfaitement ! J'ignorais cette fonction, plutôt utile !

Encore merci et bonne journée à vous !

Gasp73
 

Discussions similaires


Haut Bas