XL 2013 Problème formule =SI.NON.DISP renvoie 0

Comfortably_Numb

XLDnaute Nouveau
Bonjour à tous,

Dans un fichier Excel la formule située cellule R2 me renvoie le résultat "0" lorque je fais un TCD :

=SI.NON.DISP(RECHERCHEV(A2;TDB!D:L;9;FAUX);K2)

Le résultat "0" apparaît quand dans l'onglet TDB la formule trouve la référence souhaitée mais que la cellule où se trouve le résultat à afficher est vide. Ce que je souhaite c'est que cette formule aille voir dans l'onglet TDB si elle trouve la référence souhaitée et affiche le contenu de la cellule, sinon elle affiche K2.

Comment faire pour que ça fonctionne réellement, c'est à dire pas uniquement si la cellule dans l'onglet TDB a un contenu et surtout que je n'ai pas la valeur "0" qui ressort lorsque je fais un TCD ?

Merci à vous pour votre aide
 

Fichiers joints

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Jason,
Etant sous 2007 Si.non.disp est ... non disp !
Pourquoi ne pas essayer :
VB:
=SIERREUR(SI(RECHERCHEV(A2;TDB!D:L;9;FAUX)<>0;RECHERCHEV(A2;TDB!D:L;9;FAUX);K2);"")
Tester si la valeur vaut 0, dans ce cas il prends K2.
si erreur alors vide, mais vous pouvez mettre une valeur par defaut.
 

Comfortably_Numb

XLDnaute Nouveau
Bonjour Jason,
Etant sous 2007 Si.non.disp est ... non disp !
Pourquoi ne pas essayer :
VB:
=SIERREUR(SI(RECHERCHEV(A2;TDB!D:L;9;FAUX)<>0;RECHERCHEV(A2;TDB!D:L;9;FAUX);K2);"")
Tester si la valeur vaut 0, dans ce cas il prends K2.
si erreur alors vide, mais vous pouvez mettre une valeur par defaut.
@sylvanu le résultat qui s'affiche devient systématiquement.

Je me demande si je ne peux pas dire : tu prends la valeur de A2, tu recherches dans TDB si tu trouve la même valeur que A2, si oui tu m'affiches ce que tu trouves en colonne 9 UNIQUEMENT si le résultat est différent de ce qui se trouve en cellule K2 de mon onglet DT EI. Et en bonus, si le contenu de la colonne 9 est vide, alors tu m'affiches K2.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas