XL 2016 Problème extraction date

Théo gestin

XLDnaute Nouveau
Bonjour à tous,
J'ai un problème sur Excel, sur une feuille (Rés MRP ; T293=>T303 ; X293=>X303 ) de mon classeur lorsque je fais l'extraction d'une date à partie d'une autre feuille (Ext.Ordo ; , il m'affiche la date 01/01/1900 quelque-soit le format. Quelqu'un saurait comment retrouver un affichage normal?


Dans l'attente de votre réponse,
Merci d'avance
 

Fichiers joints

Ikito

XLDnaute Occasionnel
Bonjour Théo gestin,

Le problème n'est pas le format de la date mais le fait que la formule retourne 0. Comme les dates sont comptabilisées à partir du 1 janvier 1900, la date correspondant à 0 est 01/01/1900.

Si tu veux simplement récupérer les dates dans une feuille externe, autant utiliser RECHERCHEV comme je l'ai fait dans le fichier que je te remets en PJ.
Si le but n'est pas celui-ci, expose nous ta problématique en détail.
 

Fichiers joints

Théo gestin

XLDnaute Nouveau
Bonjour Théo gestin,

Le problème n'est pas le format de la date mais le fait que la formule retourne 0. Comme les dates sont comptabilisées à partir du 1 janvier 1900, la date correspondant à 0 est 01/01/1900.

Si tu veux simplement récupérer les dates dans une feuille externe, autant utiliser RECHERCHEV comme je l'ai fait dans le fichier que je te remets en PJ.
Si le but n'est pas celui-ci, expose nous ta problématique en détail.

Bonjour ,
Merci tout d'abord pour votre retour rapide , c'est ca le but ( extraction des dates qui correspondent aux articles fabriqués sur la feuille Ext.Ordo ) , si c'est possible , j'ai un autre souci que j'arrive pas encore à en trouver une solution , parfois on fabrique le même article , mais dans des dates différentes comme c'est le cas pour la série 1000015802 , je sais pas comment je vais afficher la deuxième date ; et merci beaucoup pour votre retour
 

Théo gestin

XLDnaute Nouveau
Bonjour Théo gestin,

Le problème n'est pas le format de la date mais le fait que la formule retourne 0. Comme les dates sont comptabilisées à partir du 1 janvier 1900, la date correspondant à 0 est 01/01/1900.

Si tu veux simplement récupérer les dates dans une feuille externe, autant utiliser RECHERCHEV comme je l'ai fait dans le fichier que je te remets en PJ.
Si le but n'est pas celui-ci, expose nous ta problématique en détail.
J'ai essayé d'appliquer la formule sur la date de début mais ça marche pas ( ça me met les dates en 01/01/1900 ) , je sais pas comment mettre la formule à jour et qu'elle retourne pas au 0 , ainsi que j'ai tiré la formule pour les autres lignes pour la colonne (date début et date de fin ) mais ça n'a pas affiché la date de tout les articles qui figurent sur la feuille Ext.ordo
et merci pour votre aide
 
Dernière édition:

frangy

XLDnaute Occasionnel
Bonjour

@ Ikito,

Tu as omis de noter une référence absolue pour la plage de recherche.
=SI(ESTNA(RECHERCHEV(A293;'Ext. Ordo.'!$C$2:$I$14;6;FAUX));"";RECHERCHEV(A293;'Ext. Ordo.'!$C$2:$I$14;6;FAUX))

J’en profite pour indiquer une autre formulation avec
=SIERREUR(INDEX('Ext. Ordo.'!H:H;EQUIV($A293;'Ext. Ordo.'!L:L;0));"")

Cordialement.
 

Théo gestin

XLDnaute Nouveau
Bonjour

@ Ikito,

Tu as omis de noter une référence absolue pour la plage de recherche.
=SI(ESTNA(RECHERCHEV(A293;'Ext. Ordo.'!$C$2:$I$14;6;FAUX));"";RECHERCHEV(A293;'Ext. Ordo.'!$C$2:$I$14;6;FAUX))

J’en profite pour indiquer une autre formulation avec
=SIERREUR(INDEX('Ext. Ordo.'!H:H;EQUIV($A293;'Ext. Ordo.'!L:L;0));"")

Cordialement.
Bonjour Frangy ,
Merci énormément ça marche niquel la deuxième formule , par contre est ce que vous saurez comment on peut faire pour insérer une ligne avec les mêmes données , si on produit deux fois le même article dans deux dates différentes svp
et merci d'avance
 

Ikito

XLDnaute Occasionnel
Théo gestin,

Pour ton second problème, voici la macro qui va pouvoir t'aider :

VB:
Sub Recherche()

Set ws_Ext = Sheets("Ext. Ordo.")
Set ws_Res = Sheets("Rés MRP")

ws_Ext.Activate

NbLigne = Application.WorksheetFunction.CountA(Columns(1))

ws_Res.Activate

For i = 293 To 308
    For j = NbLigne To 2 Step -1
        If (ws_Ext.Cells(j, "C") = ws_Res.Cells(i, "A")) Then
            ws_Res.Cells(i, "T") = ws_Ext.Cells(j, "F")
            ws_Res.Cells(i, "V") = ws_Ext.Cells(j, "G")
            ws_Res.Cells(i, "X") = ws_Ext.Cells(j, "H")
            ws_Res.Cells(i, "AA") = ws_Ext.Cells(j, "I")
            Exit For
        End If
    Next
Next

End Sub
 

Ikito

XLDnaute Occasionnel
Bonjour

@ Ikito,

Tu as omis de noter une référence absolue pour la plage de recherche.
=SI(ESTNA(RECHERCHEV(A293;'Ext. Ordo.'!$C$2:$I$14;6;FAUX));"";RECHERCHEV(A293;'Ext. Ordo.'!$C$2:$I$14;6;FAUX))

J’en profite pour indiquer une autre formulation avec
=SIERREUR(INDEX('Ext. Ordo.'!H:H;EQUIV($A293;'Ext. Ordo.'!L:L;0));"")

Cordialement.
Exact, merci :)
 

Théo gestin

XLDnaute Nouveau
Théo gestin,

Pour ton second problème, voici la macro qui va pouvoir t'aider :

VB:
Sub Recherche()

Set ws_Ext = Sheets("Ext. Ordo.")
Set ws_Res = Sheets("Rés MRP")

ws_Ext.Activate

NbLigne = Application.WorksheetFunction.CountA(Columns(1))

ws_Res.Activate

For i = 293 To 308
    For j = NbLigne To 2 Step -1
        If (ws_Ext.Cells(j, "C") = ws_Res.Cells(i, "A")) Then
            ws_Res.Cells(i, "T") = ws_Ext.Cells(j, "F")
            ws_Res.Cells(i, "V") = ws_Ext.Cells(j, "G")
            ws_Res.Cells(i, "X") = ws_Ext.Cells(j, "H")
            ws_Res.Cells(i, "AA") = ws_Ext.Cells(j, "I")
            Exit For
        End If
    Next
Next

End Sub
Comme j'ai jamais fais du vba , je sais pas pourquoi ca marche pas ( msg d'erreur : " L'indice n'appartient pas à la sélection" ) , ainsi quand j'applique la formule pour les dates ca les affiche pas tous Capture.PNGcp.PNG
 

Ikito

XLDnaute Occasionnel
Re,

Avec formules, on obtient :

1035816

Avec Macro, je dois jeter à nouveau un coup d'oeil, pour ton deuxième problème.
 

Discussions similaires


Haut Bas