Problème de simplification de formules

bcharef

XLDnaute Accro
Bonjour à toutes et à tous.

Mon objectif est de simplifier des formules .

Code:
=SI(GAUCHE($A2;1)="1";"BILAN";SI(GAUCHE($A2;1)="2";"BILAN";SI(GAUCHE($A2;1)="3";"BILAN";SI(GAUCHE($A2;1)="4";"BILAN";SI(GAUCHE($A2;1)="5";"BILAN";SI(GAUCHE($A2;1)="6";"RESULTAT";SI(GAUCHE($A2;1)="7";"RESULTAT";0)))))))

Afin de la simplifier , j'ai tapé la formule suivante:

Code:
=SI((GAUCHE(A12;1)*1)={1;2;3;4;5};"BILAN";"RESULTAT")

Mais, malheureusement elle n'affiche pas le bon résultat.

Comptant sur votre aimable collaboration, veuillez agréer mes salutations distinguées.

Bcharef.
 

bhbh

XLDnaute Barbatruc
Re : Problème de simplification de formules

Bonsoir,

essaie ainsi, parmi d'autres solutions....

Code:
=SI($A2<>"";SI(GAUCHE($A2;1)*1<=5;"BILAN";SI(GAUCHE($A2;1)*1<=7;"RESULTAT";0));"")

Bonne soirée
 

CISCO

XLDnaute Barbatruc
Re : Problème de simplification de formules

Bonsoir

Et peut être avec =CHOISIR(GAUCHE($A2;1);"BILAN";"BILAN";"BILAN";"4" etc

@ plus

P.S : Il y aura peut être des problèmes de format à résoudre (texte, nombre...).
 
Dernière édition:

souleiade

XLDnaute Nouveau
Re : Problème de simplification de formules

Bonsoir,

La solution de Bhbh est très bien, probablement la plus simple. Elle correspond tout à fait à l'exemple que tu nous a donné dans ta formule.
En revanche, si "Bilan" devait être affiché pour les valeurs 1,3,6 et "Résultat" devait être affiché pour les valeurs 2,4,5,7, elle ne fonctionnerait plus.

Pour résumer, si les plages de valeurs donnant le même résultat ne sont pas contiguës, je te conseille la formule suivante, qui te permet plus de souplesse (mais un peu moins de simplicité, j'en conviens) :
Code:
=SI($A2<>"";SI(OU((GAUCHE($A2;1)*1=1);(GAUCHE($A2;1)*1=2);(GAUCHE($A2;1)*1=3);(GAUCHE($A2;1)*1=4);(GAUCHE($A2;1)*1=5));"BILAN";SI(GAUCHE($A2;1)*1=7;"RESULTAT";0));"")

Bonne soirée
 

bcharef

XLDnaute Accro
Re : Problème de simplification de formules

Bonsoir bhbh,
Bonsoir à toutes et à tous.

J'ai le grand plaisir de vous remercier pour la solution d'une part et pour le temps que vous m'aviez accorder d'autre part.

Cordialement.

Bcharef.
 

bcharef

XLDnaute Accro
Re : Problème de simplification de formules

Bonsoir CISCO & souleiade,
Bonsoir à toutes et à tous.

Pas vu, car, j'été sous excel.

A cet effet, j'ai le grand plaisir de vous remercier et de bien vouloir m'accordier un temps pour l'exploitation de vos propositions.

Cordialement.

Bcharef.
 
Dernière édition:

bcharef

XLDnaute Accro
Re : Problème de simplification de formules

Bonsoir à toutes et à tous.

J'aimerai bien simplifier la formule suivante:

Code:
=SI(B15=1;RECHERCHEV(A16;A2:B8;2;0);SI(B15=2;RECHERCHEV(A16;C2:D8;2;0);SI(B15=3;RECHERCHEV(A16;E2:F8;2;0);SI(B15=4;RECHERCHEV(A16;G2:H8;2;0);SI(B15=5;RECHERCHEV(A16;I2:J8;2;0);SI(B15=6;RECHERCHEV(A16;K2:L8;2;0);SI(B15=7;RECHERCHEV(A16;M2:N8;2);"Enexistant")))))))

Un exemple du problème ci joint.

A vous lire et je vous remercie encore une fois d'avance.

Cordialement.

Bcharef.
 

Pièces jointes

  • Bch Recherchev.xls
    17.5 KB · Affichages: 58

CISCO

XLDnaute Barbatruc
Re : Problème de simplification de formules

Bonsoir

Toujours le même type de formule, à compléter :
= CHOISIR(B15;RECHERCHEV(A16;A2:B8;2;0);RECHERCHEV(A16;C2:D8;2;0);RECHERCHEV(A16;E2:F8;2;0);RECHERCHEV(A16;G2:H8;2;0);….)

@ plus
 

bcharef

XLDnaute Accro
Re : Problème de simplification de formules

Re bonsoir CISCO
Re bonsoir à toutes et à tous.


Je vous remercie encore une fois d'avoir pencher sur mon problème.

Il est à siganler que, je viens de découvrir et de pratiquer la fonction CHOISIR(), qui donne de bon résultats.

En cas d'autres propositions, tel qu'une formule matricielle.

Cordialement.

Bcharef.
 

bcharef

XLDnaute Accro
Re : Problème de simplification de formules

Re bonsoir CISCO,
Re bonsoir à toutes et tous.

Toujours le même type de formule, à compléter :
= CHOISIR(B15;RECHERCHEV(A16;A2:B8;2;0);RECHERCHEV(A 16;C28;2;0);RECHERCHEV(A16;E2:F8;2;0);RECHERCHEV (A16;G2:H8;2;0);….)

J'ai substitué la cellule B15 par un texte soit "A", la formule m' a affiché #VALEUR!

Et, en réalité la cellule B15 doit contenir un texte et non un nombre.

Alors, je me retrouve devant un problème à résoudre.

Cordialement.

Bcharef.
 

bcharef

XLDnaute Accro
Re : Problème de simplification de formules

Bonjour à toutes et à tous.

Je suis toujours en attente de la simplification des deux formules citées ci dessus.

Comptant sur votre aimable collaboration, veuillez agréer mes salutations distinguées.

Bcharef.
 

Tibo

XLDnaute Barbatruc
Re : Problème de simplification de formules

Bonjour,

Peut-être un début de piste avec cette formule :

Code:
=RECHERCHEV(B15;DECALER($A$1;1;(B13*2)-2;7;2);2;0)

Je te laisse tester

@+
 

bcharef

XLDnaute Accro
Re : Problème de simplification de formules

Bonjour Tibo,
Bonjour à toutes et à tous.

J'ai le grand plaisir de vous remercier pour la solution qui a affiché de bon résultat.


Mais, il utile de vous informer que la cellule B13 du présent exemple doit contenir un texte au lieu d'un nombre.

Veuillez bien consulter le fichier ci joint.

Cordialement.

Bcharef.
 

Pièces jointes

  • Bch Recherchev V(1).xls
    18 KB · Affichages: 43
  • Bch Recherchev V(1).xls
    18 KB · Affichages: 43
  • Bch Recherchev V(1).xls
    18 KB · Affichages: 48

Tibo

XLDnaute Barbatruc
Re : Problème de simplification de formules

re,

Avec un test sur le contenu du B13 :

Code:
=SI(ESTTEXTE(B13);"";RECHERCHEV(B15;DECALER($A$1;1;(B13*2)-2;7;2);2;0))

@+

Edit :

Autre approche :

Code:
=SI(OU(B13>NBVAL(1:1);ESTTEXTE(B13));"";RECHERCHEV(B15;DECALER($A$1;1;
(B13*2)-2;7;2);2;0))

@+
 
Dernière édition:

abcd

XLDnaute Barbatruc
Re : Problème de simplification de formules

Bonjour,

Proposition de formule sous la pièce jointe.
Vois si cela peut te convenir.

abcd
 

Pièces jointes

  • bcharef.xls
    18 KB · Affichages: 56
  • bcharef.xls
    18 KB · Affichages: 58
  • bcharef.xls
    18 KB · Affichages: 54
Haut Bas