Problème de macro qui fonctionne ou pas

Vieupot

XLDnaute Occasionnel
Bonjour à tous
Pépère à encore des problèmes...Faut dira ça ne fait que 3 semaines que je me suis lancé dans les codes VBA et le Cerveau ramollit

J'ai créé " à ma façon une macro qui copie un groupe de cellules qui contient des formules.
Dans une feuille de calcul la macro fonctionne trés bien
dans une autre feuille sur un autre classeur la première fois que je clique sur le bouton de commande la copie se fait parfaitement, et si je clique à nouveau, l'environnement se copie bien mais certaines cellules avec des calculs ne s'adaptent pas à la nouvelle zône créée mais garde les formules de la zone initiale de ou vient la copie.
J'ai du mal à comprendre le pourquoi

Voici la macro " a ma sauce débutant " certainement à simplifier !


Sub Macro8()

' crée une nouvelle zone de saisie dépenses
'

'
ActiveSheet.Unprotect "1234"
Range("V1:AF9").Select
Selection.Copy
Range("A65536").Select
Selection.End(xlUp).Offset(1, 0).Select
Selection.PasteSpecial Paste:=xlPasteFormulasAndNumberFormats, Operation:= _
xlNone, SkipBlanks:=False, Transpose:=False
Selection.PasteSpecial Paste:=xlPasteFormats, Operation:=xlNone, _
SkipBlanks:=False, Transpose:=False
ActiveSheet.Paste
Range("D10").Select
ActiveSheet.Protect "1234", True, True, True

End Sub



merci si quelqu'un à une idée du problème
Bernard
 

Pièces jointes

  • Classeur2.xlsm
    24.9 KB · Affichages: 39

Vieupot

XLDnaute Occasionnel
Bonjour
Merci Laurent, je vais voir pour modifier, mais je crains qu'à la créations de la fiche suivante ça fasse toujours référence à D7
Autre remarque, j'ai tout effacer les zones de copie, arrêté et remis l'ordi en marche et curieusement " pour l'instant " ça fonctionne parfaitement
Merci encore d'avoir répondu
 

Discussions similaires

Réponses
38
Affichages
1 K
Haut Bas