Autres Probleme de formules qui fonctionne pas

LUYGYS

XLDnaute Occasionnel
Bonjour et voila un probléme un enigme peut etre pas , si quelqu'un c est pourquoi ca marche pas la cellule d 9 et la cellule d 11 sont rempli d apres la ,cellle C3 et C4 or si on enleve 20 de la cellule C3 le calcul en D13 et D15 ne ce fait pas mais si on enleve le 10 de la cellule C4 oui....pourquoi..
LUYGYS
 

Fichiers joints

job75

XLDnaute Barbatruc
Bonsoir LUYGYS,

Si les formules ne font pas ce que vous souhaitez il faut les modifier, c'est tout.

A+
 

Dranreb

XLDnaute Barbatruc
Bonsoir
Ça vient probablement de ce qu'une formule de rappel de la valeur d'une cellule vide renvoie 0, or vous testez si c'est un texte vide
Essayez en D9 :
Code:
=SI(ESTVIDE(C3);"";C3)
et en D11 :
Code:
=SI(ESTVIDE(C4);"";C4)
 

LUYGYS

XLDnaute Occasionnel
Bonsoir
Ça vient probablement de ce qu'une formule de rappel de la valeur d'une cellule vide renvoie 0, or vous testez si c'est un texte vide
Essayez en D9 :
Code:
=SI(ESTVIDE(C3);"";C3)
et en D11 :
Code:
=SI(ESTVIDE(C4);"";C4)
Bonjour....! Encore une fois aprés avoir teste votre code en D9 et D11 ça ne marche pas toujours, j' envoi le fichier avec test suivi de votre conseil malheureusement la solution n' est pas trouvée encore. !!
Cordialement
LUYGYS
 

Fichiers joints

LUYGYS

XLDnaute Occasionnel
Bonjour ! vous avez raison j' ai essaie plusieurs solutions conseillees mais pas trouvez encore avez une idée....... ;)
DERNIERE MINUTE....le probléme est résolu si la cellulle D9 ou D11 est rempli a partir des celulles C3 ou C4 provenant d 'une autre feuille mais persiste si proviennent de la meme feuille ......, , , ? ? ? ? ? why ? that is the question ? LUYGYs ;)
 

LUYGYS

XLDnaute Occasionnel
Bonsoir
Ça vient probablement de ce qu'une formule de rappel de la valeur d'une cellule vide renvoie 0, or vous testez si c'est un texte vide
Essayez en D9 :
Code:
=SI(ESTVIDE(C3);"";C3)
et en D11 :
Code:
=SI(ESTVIDE(C4);"";C4)
DERNIERE MINUTE....le probléme est résolu si la cellulle D9 ou D11 est rempli a partir des celulles C3 ou C4 provenant d 'une autre feuille mais persiste si proviennent de la meme feuille ......, , , ? ? ? ? ? why ? that is the question ? LUYGYs ;)
 

job75

XLDnaute Barbatruc
Bonjour LUYGYS,

Quand j'ouvre vos fichiers des posts #4 et #5 je trouve la valeur d'erreur #NOM? en E2 et en E4.

Une raison possible de cette erreur est que la formule en E2 =SI(ESTVIDE(B3);"";B3) a été entrée avec une version anglaise d'Excel.

Avec une version anglaise il faut entrer en E2 la formule =IF(ISBLANK(B3),"",B3)

Par ailleurs dans la formule en D13 il faut remplacer E13 par D11.

Bonne journée.
 

Dugenou

XLDnaute Barbatruc
Supporter XLD
Bonjour,
en D13 votre formule =SI(D11 = "";E13;D9)-D15 ne peut pas marcher car en E13 vous avez un texte
essayez plutot =SI(D11 = "";D11;D9)-D15

Cordialement
 

job75

XLDnaute Barbatruc
Bonjour Dugenou,

C'est ce que j'ai dit au post #8... Et si c'est une version anglaise il faut =IF(D11="",D11,D9)-D15

A+
 

Dranreb

XLDnaute Barbatruc
Bonjour.
le probléme est résolu si la cellulle D9 ou D11 est rempli a partir des celulles C3 ou C4 provenant d 'une autre feuille mais persiste si proviennent de la meme feuille ......, , , ? ? ? ? ? why ?
Là D9 et D11 proviennent de C3 et C4 de la même feuille, or en rendant la formule de D13 conforme à sa description en E13 et du coup comme celle indiquée par @job75 et @Dugenou, on a bien H: 9, V: 1 si C3 vide, C4 =10 et H: 18, V: 2 si C3 =20, C4 vide.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas