Microsoft 365 problème de formule

excelsiorr

XLDnaute Nouveau
Bonjour, je suis débutant sur Excel et je suis en stage chez un concessionnaire. je viens vers vous car j'ai un petit souci, je dois rechercher une valeur dans une autre feuille Excel (20.000 lignes) , le problème étant que lorsque j'appuyes sur enter, cela m'affiche zéro. auriez vous une idée, de comment je pourrais faire? Merci d'avance

Voici La formule: =SIERREUR(RECHERCHEV($A$3;'1CPT EXPLOIT'!;$A$2$C$215;FAUX
 
Dernière édition:

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Excelsiorr,
Votre formule est :
VB:
=SIERREUR(RECHERCHEV($A$3;'1CPT EXPLOIT'!;$A$2$C$215;FAUX
et elle est fausse ( en plus de la fin que vous n'avez pas donné.
'1CPT EXPLOIT'!;$A$2$C$215 ne donne pas une plage, d'ailleurs vous auriez du avoir une erreur.
Il ne faut pas de ";" soit : '1CPT EXPLOIT'!$A$2$C$215
La syntaxe est :
VB:
SIERREUR(RECHERCHEV($A$3;'1CPT EXPLOIT'!$A$2$C$215;X;FAUX);"")
Avec X le n° de colonne où vous voulez trouver l'infos.
 
Dernière édition:

excelsiorr

XLDnaute Nouveau
Bonjour Excelsiorr,
Votre formule est :
VB:
=SIERREUR(RECHERCHEV($A$3;'1CPT EXPLOIT'!;$A$2$C$215;FAUX
et elle est fausse ( en plus de la fin que vous n'avez pas donné.
'1CPT EXPLOIT'!;$A$2$C$215 ne donne pas une plage, d'ailleurs vous auriez du avoir une erreur.
Il ne faut pas de ";" soit : '1CPT EXPLOIT'!$A$2$C$215
La syntaxe est :
VB:
SIERREUR(RECHERCHEV($A$3;'1CPT EXPLOIT'!$A$2$C$215;X;FAUX);"")
Avec X le n° de colonne où vous voulez trouver l'infos.
Tout d'abord merci pour votre aide, je vais essayer avec la formule que vous venez de me donner. encore merci!
 

excelsiorr

XLDnaute Nouveau
Bonjour Excelsiorr,
Votre formule est :
VB:
=SIERREUR(RECHERCHEV($A$3;'1CPT EXPLOIT'!;$A$2$C$215;FAUX
et elle est fausse ( en plus de la fin que vous n'avez pas donné.
'1CPT EXPLOIT'!;$A$2$C$215 ne donne pas une plage, d'ailleurs vous auriez du avoir une erreur.
Il ne faut pas de ";" soit : '1CPT EXPLOIT'!$A$2$C$215
La syntaxe est :
VB:
SIERREUR(RECHERCHEV($A$3;'1CPT EXPLOIT'!$A$2$C$215;X;FAUX);"")
Avec X le n° de colonne où vous voulez trouver l'infos.
Je reviens vers vous pour vous dire qu'avec la formule que vous m'avez donner, ils me mettent le message d'erreur "tentez vous d'effectuer une formule? si oui etc..."
 

WIsh_

XLDnaute Occasionnel
Bonjour,

A mettre dans la cellule où vous voulez afficher le résultat :

VB:
=INDEX('1CPT EXPLOIT'!$B$2:$B$20201;EQUIV(A5;'1CPT EXPLOIT'!$A$2:$A$20201;0))
ou
Code:
=INDEX('1CPT EXPLOIT'!$B$2:$B$20201;EQUIV(24558;'1CPT EXPLOIT'!$A$2:$A$20201;0))
ou
Code:
=INDEX('1CPT EXPLOIT'!$B$2:$B$20201;EQUIV("salut";'1CPT EXPLOIT'!$A$2:$A$20201;0))

=> Remplacer dans cette formule A5 par la cellule dans laquelle vous avez la valeur que vous recherchez ou par la valeur que vous recherchez (si c'est du texte, mettre des guillemets de part et d'autres.

Renvoie la valeur de la colonne B de la feuille 1CPT EXPLOIT qui se trouve sur la ligne où se situe dans la colonne A la valeur cherchée.

bàv
 

Discussions similaires

Statistiques des forums

Discussions
290 779
Messages
1 910 447
Membres
176 662
dernier inscrit
gredkowski
Haut Bas