Problème de Formule et de Recopie

blancolie

XLDnaute Impliqué
Bonsoir Le Forum,

Dans ce Fichier et l'onglet feuille equipe qui me sert à rentrer les plantes par secteur et par massif et en même temps m'afficher leurs caractéristiques ( qui se trouvent ds BDD_Fleurs) à l'aide de l'association index/equiv.

Cela marche très bien pour la première ligne mais pour la deuxième ligne cela ne marche plus. Je vois ou se trouve le problème mais je ne vois pas comment le résoudre.

Dans la formule, j'ai inséré des Si pour ne pas avoir de Zero à apparaitre si dans mon onglet BDD_Fleurs, les cellules sont vides ou différent. Différent c'est au niveau de Equiv.

Si la formule descend; c'est normal que le résultat soit différent mais la solution, je pense pas que les celllules doivent être figées.

Connaissez-vous la soution ?

Il faut corriger les Formules dans la première ligne en C4, D5,E5, Etc car si je clique sur la deuxième ligne en A5, une nouvelle ligne s'insère et les formules se recopient.

Merci de Votre aide.
 

Pièces jointes

  • Projet_Equipe_Fleurissement.xlsm
    89.6 KB · Affichages: 14

eriiic

XLDnaute Barbatruc
Bonjour,

J'ai eu un peu de mal à comprendre ta demande.
Déjà j'ai inhibé ta macro qui mettait le bazar. Inutile puisque qu'un des avantages des tableaux est justement de pouvoir ajouter une ligne facilement en recopiant formules et formats.
A la place j'ai inséré une colonne A. Y saisir x pour ajouter une ligne, comme ça tu as toujours tes listes déroulantes.
A la limite, si tu veux mettre une macro, ajoute le x sur double-clic de la 1ère cellule de A disponible.

J'ai supprimé ton Si() incohérent. A la place c'est un format personnalisé qui n'affiche pas les 0
A voir si ce principe te va.
eric

PS : j'ai fait de D à I, je viens de voir que ça continue au-delà. A toi de completer
 

Pièces jointes

  • Projet_Equipe_Fleurissement.xlsm
    90.6 KB · Affichages: 7
Dernière édition:

blancolie

XLDnaute Impliqué
merci, je vais regarder plus tard car je peux pas le faire de mon tel. De mémoire oui un tableau structuré rajoute une ligne après validation? Mais pas avant, il me semble ? Dc la la ro me permettait de l insérer une nouvelle ligne avec mes listes et formules. Les si cela fonctionne mais oui c est plus simple avec un format ou msc
 

eriiic

XLDnaute Barbatruc
rajoute une ligne après validation? Mais pas avant, il me semble ?
d'où l'ajout d'une colonne A qui ne sert qu'à ajouter la ligne.
Tu saisis "x", tu tabules et tu as ta liste déroulante dispo.
Enfin tu te rendras mieux compte avec le fichier pour voir si ça te va.
C'est indépendant de ton pb, rien ne t'empêche de remettre ta petite usine à gaz. Mais la meilleure macro c'est celle qui n'existe pas ;-)
 

blancolie

XLDnaute Impliqué
Bonjour,

j'ai regardé votre travail mais le problème persiste, ci on met la même plante, cela ne marche pas du tout. Le même problème que ma formule. j'ai plusieurs équipes et chaque équipes peuvent utiliser la même plante.
 
Dernière édition:

eriiic

XLDnaute Barbatruc
Bonjour,

Il y avait un autre Si() auquel je n'avait pas prêté attention.
Finalement je remplace tout par un simple Recherchev().
Et j'ai créé un nom pour ta liste déroulante des plantes qui ne fonctionnait pas correctement non plus.

Si tu dois modifier des formules il faut remettre le format Standard d'abord sinon elles restent en texte. Mettre le format personnalisé en dernier.
eric

PS : J'ai vu qu' apparemment tu n'as rien d'autre sur cette feuille, tu peux supprimer l'affichage des 0 dans les options avancées et conserver le format Standard
 

Pièces jointes

  • Projet_Equipe_Fleurissement.xlsm
    90.4 KB · Affichages: 3
Dernière édition:

eriiic

XLDnaute Barbatruc
Dans ce cas :
VB:
=SIERREUR(RECHERCHEV($C4;T_Datas;EQUIV(D$3;T_Datas[#En-têtes];0);FAUX);"")
J'utilise les entêtes pour pouvoir recopier la formule sans modif entre les colonnes.
Par contre il faut qu'ils soient strictement identique entre les 2 feuilles : 'N° photo' et non 'N°', 'feuille' et non 'feuilles', etc
Pour les mois (non faits) il va falloir en écrire un peu plus. J est présent 3 fois par exemple...

J'utilise maintenant l'option ne pas afficher les 0 au lieu du format personnalisé.
Un lien car on ne peut plus insérer de fichier : https://www.cjoint.com/c/JICh7o8YfFd
eric
 

blancolie

XLDnaute Impliqué
Bonsoir Eriiic, j'ai regardé ton travail et cela marche bien mais je suis têtu. Je sais que cela marche avec index et equiv et que si on descend d'une ligne en utilisant le même critère, on peut aller le récupérer en haut du tableau. Mais je vois pas comment faire.
 

Discussions similaires

Réponses
1
Affichages
522

Statistiques des forums

Discussions
297 960
Messages
1 964 647
Membres
200 629
dernier inscrit
sylvain_grosjean