XL 2016 problème de compilation de formule

Gaetan44

XLDnaute Nouveau
bonjour j'ai créer une formule qui consiste a récupérer dans la cellule A1 le jour actuelle et marquer dans la cellule C2 en fonction de l'heure si nous somme en huit du matin d'après-midi ou de nuit
=SI(NB.SI(A1;"*lundi*")+NB.SI(A1;"*mardi*")+NB.SI(A1;"*mercredi*")+NB.SI(A1;"*jeudi*");SI(HEURE(MAINTENANT())<=4;"nuit";SI(HEURE(MAINTENANT())<=12;"matin";SI(HEURE(MAINTENANT())<=20;"aprés-midi";(SI(HEURE(MAINTENANT())<=23;"nuit";))))))

Problème le vendredi les horaires changes donc j'ai noter :
=SI(NB.SI(A1;"*vendredi*");SI(HEURE(MAINTENANT())<=10;"matin";SI(HEURE(MAINTENANT())<=16;"apres-midi";SI(HEURE(MAINTENANT())<=22;"nuit"))))

je n'arrive pas a avoir ses deux formules dans la même cellule, j'aimerai que quand en A1 vendredi est noter la première formule ne s'applique pas mais la deuxième

merci d'avance de votre aide
 

Dranreb

XLDnaute Barbatruc
Bonsoir.
À essayer :
Code:
=INDEX({"nuit";"matin";"après-midi";"nuit"};EQUIV(HEURE(MAINTENANT());SI(A1="vendredi";{0;5;11;17};{0;5;13;21})))
 

Discussions similaires


Haut Bas