Probleme d'addition

milomech

XLDnaute Junior
Bonjour à toute la communauté,

Mon problème est le suivant,

je doit réalisé une moyenne mois par mois sur 10 ans

exemple j'ai :
mai2007 10
juin 2007 15
.....

mai 1980 2

je doit me retrouver avec
une moyenne pour janvier
une moyenne pour fevrier
... moyenne pour décembre soit 12 moyenne


Quel est la formule a utilisé rechercher valeur si....

merci pour votre aide si joint une partie du fichier

merci
 

Fichiers joints

mth

XLDnaute Barbatruc
Re : Probleme d'addition

Bonjour,

Les libellés des mois ne sont pas rigoureusement tous les mêmes que ceux de ton tableau récap, du coup dans le doute, essaie cette formule peut-être?:

Code:
=MOYENNE.SI($A$10:$A$434;COLONNE()-7;$D$10:$D$434)
En H16 et recopiée vers la droite

@ +

mth

Edit :) Grosse bise JC :) :)
 
Dernière édition:

JCGL

XLDnaute Barbatruc
Re : Probleme d'addition

Bonjour à tous,
Salut Mimi :):),

MOYENNE.SI() n'étant pas applicable sous XL2003 et pour le plaisir de croiser MTH, je propose pour les XL 2003 (bien qu'il soit précisé XL 2007 dans le titre) :

Quand tous les mois de 2010 seront renseignés :
Code:
=SOMMEPROD(($A$10:$A$434=COLONNE(A1))*$D$10:$D$434)/(MAX($C:$C)-MIN($C:$C)+1)
Avec les cinq premiers de 2010 renseignés :
Code:
=SOMMEPROD(($A$10:$A$434=COLONNE(A1))*$D$10:$D$434)/(NB.SI($A:$A;COLONNE(A1)))
Bises ++ Mimi
A+ à tous
 
Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas