XL 2010 Problème avec INDEX + SOMMEPROD qui renvoie un résultat erroné si conditions non remplies

Philippe LAMACHE

XLDnaute Junior
Bonjour à tous,
Dans le fichier joint, je tente de trouver la valeur correspondant à 4 critères par une formule (trouvée sur le Net).

=INDEX(ANIMAL;SOMMEPROD((Liste_SEXE=B2)*(Liste_COULEUR=C2)*(Liste_RACE=D2)*(Liste_POILS=E2)*LIGNE(Liste_ANIMAL)))

Mon souci est que :
- Quand les 4 conditions sont réunies => la formule "match" bien et me renvoie le bon résultat.
- Quand les 4 conditions NE sont PAS réunies => la formule me donne le résultat correspondant à la valeur de la ligne où est la formule au lieu de 'Erreur' ou 'Rien' ou 'Faux'.

Je n'arrive pas à gérer le "Non match" de ma formule afin d'écrire un texte quand la formule ne trouve pas la correspondance.

Pouvez-vous m'aider ?
Par avance, merci.
 

Fichiers joints

Bebere

XLDnaute Barbatruc
bonjour
à tester
en A2 et recopier vers le bas
=SI(SOMMEPROD((Liste_SEXE=B2)*(Liste_COULEUR=C2)*(Liste_RACE=D2)*(Liste_POILS=E2))=0;"";INDEX(ANIMAL;SOMMEPROD((Liste_SEXE=B2)*(Liste_COULEUR=C2)*(Liste_RACE=D2)*(Liste_POILS=E2)*LIGNE(Liste_ANIMAL))))
 

Spinzi

XLDnaute Impliqué
Bonjour, Philippe, Bebere,

en lieu et place de votre sommeprod, j'utiliserai un index equiv multicritères (a coller en cellule A2), à valider en matriciel grâce aux touches CTRL + MAJ + ENTREE :
Code:
=INDEX(Liste_ANIMAL;EQUIV(B2&C2&D2&E2;Liste_SEXE&Liste_COULEUR&Liste_RACE&Liste_POILS;);1)
La formule se décompose comme un index/equiv habituel, seulement on concatène les champs de critères entre eux puis on concatène les matrices de recherche des critères.
Il suffit donc de rajouter un SIERREUR pour la gestion des N/A.

Spinzi
 

Philippe LAMACHE

XLDnaute Junior
bonjour
à tester
en A2 et recopier vers le bas
=SI(SOMMEPROD((Liste_SEXE=B2)*(Liste_COULEUR=C2)*(Liste_RACE=D2)*(Liste_POILS=E2))=0;"";INDEX(ANIMAL;SOMMEPROD((Liste_SEXE=B2)*(Liste_COULEUR=C2)*(Liste_RACE=D2)*(Liste_POILS=E2)*LIGNE(Liste_ANIMAL))))
Bonjour Bebere,
Merci pour ta réponse rapide.
Cela fonctionne parfaitement.
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas