Microsoft 365 Pointer vers une cellule

Nico1972

XLDnaute Nouveau
Bonjour,
J'ai un inventaire à faire, la base de donnée fait environ 10.000 références avec des codes-barres type chiffre ou texte.
L'idée est de biper le code-barre dans une cellule et de rechercher automatiquement la ligne correspondante pour modifier la quantité.
J'ai essayé avec lien_hypertexte mais je rencontre des difficultés ; lorsque je nomme les lignes par un identifiant (formules -> depuis selection), il me met un _ en première position pour les codes-barres en chiffres et un _ en dernière position pour les codes-barres avec des lettres.
Merci d'avance pour votre aide.
Nicolas
 

Roblochon

XLDnaute Barbatruc
Bonjour,

Lorsque excel nomme automatiquement des cellules il remplace les caractères interdits dans les noms par '_' (underscore ou tiret-bas). Votre logiciel créateur de codes barre, doit certainement insérer un caractère interdit dans les noms en début ou fin de cellule.

Sans fichier exemple, je n'irai pas plus loin tant les cas sont différents d'une application ou fichier à l'autre.

cordialement
 

Nico1972

XLDnaute Nouveau
Ci-joint le ficher exemple
si je fais une recherche avec les codes-barres en chiffre, pas de pb.
les codes-barres en lettre posent problèmes (lors de la création, le _ s'est positionné à gauche)
 

Fichiers joints

Roblochon

XLDnaute Barbatruc
Bonjour,

Ci-jointe une solution par formule, plus besoin des noms :
=LIEN_HYPERTEXTE("#A" & 4+ SIERREUR( EQUIV($B$2;$A$5:$A$10000;0);0);"Rechercher")

cordialement
 

Fichiers joints

Nico1972

XLDnaute Nouveau
merci beaucoup pour cette solution efficace
une dernière question, comment placer le curseur automatiquement dans la colonne quantité ?
 

Roblochon

XLDnaute Barbatruc
Re,

Une version 'améliorée' du précédent fichier :

1 - création d'un nom 'CodeBarre.Index' définit ainsi : =SIERREUR( EQUIV(Feuil1!$B$2;Feuil1!$A$5:$A$10000;0);0)

2 - formule du lien hypertexte modifiée LIEN_HYPERTEXTE("#A" & 4+CodeBarre.Index;"Rechercher")

3 - Une mise en forme conditionnelle pour mettre en rouge B2 si code non trouvé et une autre en vert si trouvé

4 - Mise en forme conditionnelle de la ligne trouvée.

une dernière question, comment placer le curseur automatiquement dans la colonne quantité ?
Dans votre exemple, il n'y a pas de noms de colonnes. Mais il suffit de remplacer "#A" dans la formule de lien par la lettre idoine de la colonne.

A ce propos vous avez excel 365 pourquoi ne pas utiliser les tableaux structurés ?
Les tableaux structurés vous permettraient aussi de manipuler vos données avec powerquery (inclus dans votre version )
cordialement
 

Fichiers joints

Dernière édition:

Nico1972

XLDnaute Nouveau
Bonjour,
J'ai un problème avec le format des cellules pointées.
par exemple :
ligne 6, la recherche est correcte
ligne 13, la recherche n'est pas correcte
je vous joint le fichier pour exemple
Par avance, merci
Nicolas
 

Fichiers joints

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas