Plus grande valeur correspondant a un doublon

Dugenou

XLDnaute Barbatruc
Re : Plus grande valeur correspondant a un doublon

Bonjour,
formule matricielle à valider par ctrl+maj+enter puis recopier vers le bas
=MAX($B$2:$B$10*($A$2:$A$10=A2))
 

david84

XLDnaute Barbatruc
Re : Plus grande valeur correspondant a un doublon

Bonsoir,
à tester (validation matricielle) :
Code:
=MAX(SI(A$2:A$10=A2;B$2:B$10))
A+
 

antiphot

XLDnaute Occasionnel
Re : Plus grande valeur correspondant a un doublon

Merci à vous deux. Les deux solutions fonctionnent parfaitement
 

R@chid

XLDnaute Barbatruc
Re : Plus grande valeur correspondant a un doublon

Bonsoir @ tous,
Une astuce de Monique pour éviter la validation matricielle,
en C2,
Code:
=SOMMEPROD(MAX((A$2:A$10=A2)*B$2:B$10))
@ tirer vers le bas

Lien

Sinon, si les données sont bien triées sur la colonne A comme sur l'image,
en C2,
Code:
=MAX(DECALER(B$1;EQUIV(A2;A$2:A$10;0);;NB.SI(A$2:A$10;A2)))
@ tirer vers le bas
Comme ça en évite les matricielles


@ + +
 
Dernière édition:

Monique

XLDnaute Barbatruc
Re : Plus grande valeur correspondant a un doublon

Bonjour,

Ou encore
Code:
=SOMMEPROD(MAX(B$2:B$10*(A$2:A$10=A2)))
à valider simplement par « Entrée »

Edit - Message en doublon - Pas vu ton message, R@chid
 
Dernière édition:

R@chid

XLDnaute Barbatruc
Re : Plus grande valeur correspondant a un doublon

Re,
Salut Monique je viens de proposer ta formule avec le lien :D :)

@ + +
 

Discussions similaires


Haut Bas