Résolu XL 2013 Planning utilisation véhicule par tranches horaires

Rom_02200

XLDnaute Nouveau
Bonjour à tous,

Merci pour ce forum grâce auquel je progresse sur Excel. Mais là je sèche complètement et je ne trouve pas de solution ici ou là car sans doute je ne sais pas bien formuler ma demande. Donc je vais essayer d'être explicite:

A partir d'une base de donnée de transport à la demande j'extrait l'horaire de départ et ensuite je crée des classes horaires. Ces données sont de forme verticale. Je souhaite faire ensuite un planning de manière horizontale avec les classes horaires et les numéros de lignes. Ensuite je mets une une formule SI(NB.SI) pour indiquer véhicule dans la cellule correspondant au numéro de classe de déclenchement du transport. Ensuite par une mise en forme conditionnelle, je colore la cellule.
Cette méthode me permet d'avoir le résultat escompté. Mais je cherche une formule global qui m'éviterai de devoir changer manuellement ma plage (car plusieurs centaines de ligne parfois dans ma BDD) dans ma formule NB.SI. J'ai essayé en imbriquant plusieur SI ou avec RECHERCHV mais ca ne fonctionne pas (ou plus excatement je n'y suis pas arrivé).

Merci pour votre aide

Bonne journée à vous et prenez soin de vous et de vos proches en cette période difficile.
 
Ce fil a été résolu! Aller à la solution…

Fichiers joints

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Rom,
Un début de piste.
Cette formule en I4 :
Code:
=NB.SI.ENS($A:$A;$H4;$C:$C;$I4;$D:$D;">=" &I$2;$D:$D;"<" & J$2)
Compte le nombre d’occurrences de TAD1, vers A, entre 00:05 et 05:50
L'avantage est que les référence sont les colonnes et donc indépendantes de la taille de votre base de données.
Avec votre SI, ça donne :
Code:
=SI(NB.SI.ENS($A:$A;$H4;$C:$C;$I4;$D:$D;">=" &I$2;$D:$D;"<" & J$2);"Véhicule";"")
Voir PJ.
 
Ce message a été identifié comme étant une solution!

Fichiers joints

Modeste geedee

XLDnaute Barbatruc
Bonsour®
Mais je cherche une formule global qui m'éviterai de devoir changer manuellement ma plage (car plusieurs centaines de ligne parfois dans ma BDD)
;)
en quelque sorte éviter un travail de Romain ...:cool:
sans macro, quasiment sans formule (presque)
Tableau Croisé Dynamique
1585245554171.png
 
Ce message a été identifié comme étant une solution!

Fichiers joints

Rom_02200

XLDnaute Nouveau
Bonjour Sylvanu, François et Modeste geedee,

Je vous remercie pour vos solutions qui ont toutes répondus à ce que je cherche depuis plusieurs jours.

UN GRAND MERCI A VOUS

Romain
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas