1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

Planning avec demi jours

Discussion dans 'Forum Excel' démarrée par Jackoneall, 4 Décembre 2018.

  1. Jackoneall

    Jackoneall XLDnaute Nouveau

    Inscrit depuis le :
    4 Décembre 2018
    Messages :
    3
    "J'aime" reçus :
    0
    Bonjour,

    j'ai repris un planning sur le net, et je voudrais l'adapter en essayant d'introduire les demi-jours d'absences
    Donc l'utilisateur introduit une date en (B12:I16) et le planning se rempli par MFC
    la formule est celli-ci

    =SI(OU(J$11="D";J$11="S");"";SI(OU(ET(J$10>=$B12;J$10<=$C12);ET(J$10>=$D12;J$10<=$E12);ET(J$10>=$F12;J$10<=$G12);ET(J$10>=$H12;J$10<=$I12));1;""))

    Donc si la formule retourne 1 (se met en bleu)MFC

    Donc ma question, comment adapter la formule pour pouvoir introduire de la même manière les demi-jours?

    merci à vous
     

    Pièces jointes:

  2. Chargement...

    Discussions similaires - Planning demi jours Forum Date
    XL 2010 Planning avec demi-journée et mfc Forum Excel 15 Mars 2018
    Planning congés, demi jour Forum Excel 7 Octobre 2010
    XL 2013 Remplir un planning selon un EDT type Forum Excel 2 Février 2019
    XL 2013 Planning des recettes et liste de course Forum Excel 27 Janvier 2019
    planning dynamique Forum Excel 16 Janvier 2019

  3. Jackoneall

    Jackoneall XLDnaute Nouveau

    Inscrit depuis le :
    4 Décembre 2018
    Messages :
    3
    "J'aime" reçus :
    0
    Bonjour ,

    Un début d'idée avec la formule

    =SI(OU(R$11="D";R$11="S");"";SI(OU(ET(R$10>=$B16;R$10<=$C16);ET(R$10>=$D16;R$10<=$E16);ET(R$10>=$F16;R$10<=$G16);ET(R$10>=$H16;R$10<=$I16));SI(MOD(C16;2)=1;1;0,5);""))
     

    Pièces jointes:

  4. Jackoneall

    Jackoneall XLDnaute Nouveau

    Inscrit depuis le :
    4 Décembre 2018
    Messages :
    3
    "J'aime" reçus :
    0
    Bonjour personne n'a une idée?
     

Partager cette page