Planning avec demi jours

Jackoneall

XLDnaute Nouveau
Bonjour,

j'ai repris un planning sur le net, et je voudrais l'adapter en essayant d'introduire les demi-jours d'absences
Donc l'utilisateur introduit une date en (B12:I16) et le planning se rempli par MFC
la formule est celli-ci

=SI(OU(J$11="D";J$11="S");"";SI(OU(ET(J$10>=$B12;J$10<=$C12);ET(J$10>=$D12;J$10<=$E12);ET(J$10>=$F12;J$10<=$G12);ET(J$10>=$H12;J$10<=$I12));1;""))

Donc si la formule retourne 1 (se met en bleu)MFC

Donc ma question, comment adapter la formule pour pouvoir introduire de la même manière les demi-jours?

merci à vous
 

Fichiers joints

Jackoneall

XLDnaute Nouveau
Bonjour ,

Un début d'idée avec la formule

=SI(OU(R$11="D";R$11="S");"";SI(OU(ET(R$10>=$B16;R$10<=$C16);ET(R$10>=$D16;R$10<=$E16);ET(R$10>=$F16;R$10<=$G16);ET(R$10>=$H16;R$10<=$I16));SI(MOD(C16;2)=1;1;0,5);""))
 

Fichiers joints

Discussions similaires


Haut Bas