Planning automatique en vba (Résolu par Dranreb)

fenec

XLDnaute Impliqué
Bonjour le forum,

Il y quelque temps DRANREB m’avait aidé pour automatiser mon planning en vba.

Vous joint le lien de la discussion
https://www.excel-downloads.com/threads/planing-cyclique-par-dranreb.20004337/

Aujourd’hui, on me demande de refaire la même chose avec une nouvelle mise en page mais je ne parviens pas à modifier les macros

Le résultat souhaité est dans le fichier joint

Merci d’avance pour l’aide que vous pourriez m’apporter.

Cordialement,

Philippe.
 

Fichiers joints

Dranreb

XLDnaute Barbatruc
Bonjour.
Peut être auriez vous intérêt à le faire avec une formule qui n'utilise plus CYC…
En D4, à propager sur 31 lignes et 5 colonnes :
Code:
=STXT("MMSSNN----";MOD($B4+2-2*D$3;10)+1;1)
Voire cette formule, valable pour tous les mois :
Code:
=STXT("MMSSNN----";MOD(DECALER($B4;0;ENT((COLONNE()-1)/8)*8)+2-2*D$3;10)+1;1)
 

fenec

XLDnaute Impliqué
Bonjour le forum, Dranreb
Tout d'abord pardon pour la réponse tardive.
Merci pour ton aide et ta solution qui fonctionne parfaitement.
J'ai donc fait mes MFC sans me servir du vba aussi.
Je vais maintenant essayer ta solution pour d'autre cycle et vous contacterais en cas de problème
Encore merci,
Cordialement,
Philippe.
 

fenec

XLDnaute Impliqué
Bonsoir le forum, Dranreb
Je reviens vers vous car je n'arrive pas à appliquer votre formule pour mes autres cycles
Jai essayé ceci pour mon cycle en 3x8 mais j'obtiens un décalage
Code:
=SI($B7="";"";STXT("MMMMM--SSSSS--NNNNN--";MOD($B7+2-4*D$6;21)+1;1))
pour ce qui est de la formule pour tout les mois je n'y suis pas parvenu si je fais ceci j'ai toujours la même réponse avec une erreur de référence circulaire.
Code:
=STXT("MMMMM--SSSSS--NNNNN--";MOD(DECALER($B7;0;ENT((COLONNE()-1)/5)*5)+2-4*D$6;21)+1;1)
Pour ce qui est de mon cycle SD je n'ai rien trouvé
D'avance merci pour votre aide
Cordialement,
Philippe.
 

Fichiers joints

fenec

XLDnaute Impliqué
Re le forum, bonsoir Dranreb
En effet vous avez raison mais cela ne règle pas le problème.
Je continue à chercher
 

Dranreb

XLDnaute Barbatruc
Mon Excel me détecte un contenu illisible quand j'ouvre le classeur joint, et il supprime ensuite les contenus des colonnes H et I
Par ailleurs ce n'est pas 4*la valeur portée dans la ligne 6 qu'il faut ajouter ou enlever, bien sur mais plutôt 7 ou 14 ça dépend du sens du décalage. 21 n'est pas un multiple de 4.
 
Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas