XL 2016 Petit soucis sur une plage horaire (16:15)

Martin11

XLDnaute Nouveau
Bonjour à tous,

Sur mon fichier Game Plan lorsque je mets des plages horaires (ex: "8:00" "18:00") il y a des cases grises qui apparaissent de 8h à 18h ( il y aura un exemple dans ma PJ)

Cependant j'ai juste un soucis sur la cellule 16:15 car elle ne veut pas se colorer en grise comme toutes les autres lorsque c'est demandé.
C'est à dire si je mets 8:00/16:00 ou 8:00/ 16:15 , Le quart d'heure ne va pas se colorer en gris.
J'ai juste se soucis pour ce 15min sinon tout le reste fonctionne correctement


Commet puis-je faire ?

Merci pour votre aide

Martin11
 

Fichiers joints

M12

XLDnaute Accro
Bonjour,
Le problème vient du fait d'avoir mis ta ligne d'horaire par une formule (heure + 15 minutes) que tu as ensuite copier/coller en valeur
sauf que cela ne tombe pas juste.
Si tu mets manuellement ton horaire dans la ligne 4 cela fonctionnera (tu auras le même problème à 17:00 etc...
 

Dranreb

XLDnaute Barbatruc
Bonjour.
Vous pouvez aussi mettre en F4, à propager sur 55 colonnes :
Code:
=ENT(E4*96+1,5)/96
Ou bien d’ailleurs en E4, à propager sur 56 colonnes :
Code:
=(COLONNE()+27)/96
Rétablir le format hh:mm
 
Dernière édition:

Martin11

XLDnaute Nouveau
Bonjour,
Le problème vient du fait d'avoir mis ta ligne d'horaire par une formule (heure + 15 minutes) que tu as ensuite copier/coller en valeur
sauf que cela ne tombe pas juste.
Si tu mets manuellement ton horaire dans la ligne 4 cela fonctionnera (tu auras le même problème à 17:00 etc...
D'accord mais comment je peux faire alors ?
En gros mon tableau n'est pas bon ???
 

Martin11

XLDnaute Nouveau
Bonjour.
Vous pouvez aussi mettre en F4, à propager sur 55 colonnes :
Code:
=ENT(E4*96+1,5)/96
Ou bien d’ailleurs en E4, à propager sur 56 colonnes :
Code:
=(COLONNE()+27)/96
Rétablir le format hh:mm
J'ai mis la formule dans la Cellule E4 et cela ne fonctionne pas

Je ne dois surement pas savoir le faire ! :(
 

Dranreb

XLDnaute Barbatruc
Alors mettez INT au lieu de ENT et un point au lieu de la virgule décimale, pour votre Excel anglais.
Ou pour ma seconde formule mettez COLUMN au lieu de COLONNE.
 

Modeste geedee

XLDnaute Barbatruc
Bonjour à tous,

Sur mon fichier Game Plan lorsque je mets des plages horaires (ex: "8:00" "18:00") il y a des cases grises qui apparaissent de 8h à 18h ( il y aura un exemple dans ma PJ)

Cependant j'ai juste un soucis sur la cellule 16:15 car elle ne veut pas se colorer en grise comme toutes les autres lorsque c'est demandé.
C'est à dire si je mets 8:00/16:00 ou 8:00/ 16:15 , Le quart d'heure ne va pas se colorer en gris.
J'ai juste se soucis pour ce 15min sinon tout le reste fonctionne correctement


Commet puis-je faire ?

Merci pour votre aide

Martin11
un arrondi à la 4éme décimale devrait résoudre le problème(équivaut à un arrondi à la seconde
1575666757848.png
en E9 et propagations suivantes(droite et bas )
=SI(ET(E$4>=$C9;ARRONDI(E$4;4)<=$D9);1;0)
1575666953610.png
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas