XL 2019 Perdu dans la fonction SI

Casey7134

XLDnaute Nouveau
Bonjour je reviens vers vous, car j'ai encore un souci...
Voilà, je veux faire une fonction Si donc par exemple :
A1 = A
A2 = N.A
A3 = A
A4 ==SI(A1="A";SI(A2="A";SI(A3="A";"A";"NA")))

Donc si toutes les cellules sont avec des "A" dedans la réponse vrai fonctionne, par contre si il t a un "N.A" dans une ou les 3 cellules, excel ne veut pas me mettre le texte indiquer à savoir "N.A" comme indiquer dans la formule, mais il m'indique "Faux" ?
Une idée?
Merci
Casey
 

djidji59430

XLDnaute Accro
Bonjour à tous,

normal
dans ton exemple
si a1="a" vrai==>si a2="a" faux donc on saute ton 3émé si et on retombe sur rien ==>faux

A4 =SI(A1="A";SI(A2="A";SI(A3="A";"A");"NA")) place des parenthéses

on peux simplifier ta formule en écrivant
Si(et(a1="a";a2="a";a3="a");'a';"n.a")

Crdlmt
 

Casey7134

XLDnaute Nouveau
Ok merci, je tente ça quand je rentre...
effectivement, la même formule avec 2 cellules, ça fonctionnait !
3 cellules la cata
Merci
 

Casey7134

XLDnaute Nouveau
Bon ok ça marche, merci, mais j'ai encore un autre problème dans mes 3 cellules, j'aimerais que s'il y a au moins 2 "A" sur les 3 alors c'est "A" si pas c'est "N.A"

Il faut modifié la formule comment ?
Merci
 

natorp

XLDnaute Accro
Bjr Casey et Djidji

Comme ça : =SI(OU(ET(A1="A";A2="A");ET(A1="A";A3="A");ET(A2="A";A3="A"));"A";"N.A")

Cordialement, Gérard
 

Casey7134

XLDnaute Nouveau
Merci, je n'aurais pas réussi sans vous !
je me doutais bien qu'il fallait jouer avec "et" et "ou", mais je n'ai pas tout compris à la formule...

Si j'avais eu 4 cellules, je devais faire A1 par rapport à A2, A1 p.r.à A3, A1 p.r.à A4, A2 p.r.à A3, A2 p.r.à A4, A3 p.r.à A4 ?

Merci
 

natorp

XLDnaute Accro
Re,

la question est d'abord de savoir quel est le test à réaliser ? au moins 2 "A" sur 4 ? ou au moins 3 "A" sur 4 ?

Gérard
 

Casey7134

XLDnaute Nouveau
attend, attend, je crois que j'ai compris... :p

Oui Gérard 3 A sur 4 !

J'essaie et je vous mets la formule pour me corrigé, simplement pour voir si j'ai compris !
Merci
 

Casey7134

XLDnaute Nouveau
Voilà le test est que au moins 3 "A" sur 4 pour que la réponse soir "A" sinon "N.A" !
=SI(OU(ET(A1="A";B1="A";C1="A");ET(A1="A";C1="A";D1="A");ET(B1="A";C1="A";D1="A"));"A";"N.A")
Merci pour la correction
Casey
 

natorp

XLDnaute Accro
Re,
Bonjour Casey, Victor et Djidji,
Djidji et Victor : Ce n'est pas qu'elle ne plaise ou pas, elle ne donne pas le résultat attendu : s'il n'y a que 2 "A", elle renvoie "A" alors que Casey veut "NA" ou alors je n'ai pas compris ??

Cordialement, Gérard
 

Discussions similaires


Haut Bas