Résolu XL 2019 Pb de suppression de cellules vides...

baboun

XLDnaute Nouveau
Bonjour
J"ai un souci avec la fonction atteindre les cellules vides(touche F5)
J'ai un tableau qui provient d'un copier coller (collage spécial seulement les valeurs...)
Je sélectionne ce tableau , appuie sur F5 pour atteindre les cellules vides (que je veux supprimer pour avoir un tableau compact) et là il n'y a que quelques cellules qui sont sélectionnées... ce qui est gênant...
Pourquoi ? Quelqu'un pourrait il m'aider ?
Je joins un exemple.
Merci d'avance
 
Ce fil a été résolu! Aller à la solution…

Fichiers joints

Dranreb

XLDnaute Barbatruc
Bonjour.
C'est parce seules les cellules vides sont sélectionnées et non celles remplies de textes de longueur nulle.
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonjour baboun, bienvenue sur XLD :)

Le fameux caractère vide a encore frappé :eek:.

Exemple :
  • sur une feuille, tapez la formule en A1 : = ""
  • Copier la cellule A1
  • et coller en valeur sur la cellule A1
  • A1 semble vide mais si en B1, si vous tapez la formule = TEXTE(A1), alors la formule en B1 affichera VRAI. Donc A1 n'est pas vide, c'est du texte (de longueur nulle ma foi). Elle contient le caractère vide qui n'est pas équivalent à rien.
Pour faire l’opération que vous désirez, suivre les instructions du fichier joint. Tout se fait au clavier.

edit : bonjour @Dranreb :)
 
Ce message a été identifié comme étant une solution!

Fichiers joints

Dernière édition:

baboun

XLDnaute Nouveau
Un grand merci pour vos réponses et surtout du fichier-tuto qui est très clair.

Ce qui est bizarre, c'est que le tableau que le fichier exemple que j'ai joint provenait d'un copier/collage spécial "Valeurs seulement" et que seules quelques cellules étaient sélectionnées....

Encore un grand Merci
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Ce qui est bizarre, c'est que le tableau que le fichier exemple que j'ai joint provenait d'un copier/collage spécial "Valeurs seulement" et que seules quelques cellules étaient sélectionnées....
Justement, c'est bien quand on fait des collages par valeur que le phénomène se produit. Vous avez sans doute copié des données issues de formules qui renvoient le caractère vide "".
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas