Optimisation de formule avec SOMMEPROD et SOUS.TOTAL

djodjodjo

XLDnaute Occasionnel
Bonjour à tout le forum,

J'ai une petite question (toute bête?) pour vous... en fait j'utilise la formule suivante:

Code:
=SOMMEPROD((SOUS.TOTAL(9;INDIRECT("'Tous projets'!M"&LIGNE('Tous projets'!M$42:'Tous projets'!M$2000)))*('Tous projets'!F$42:'Tous projets'!F$2000=A1)))

qui me fait la somme (fonction 9 de sous.total) des valeurs de la colonne M pour lesquelles il y a le contenu de A1 en colonne F. Elle fonctionne très bien, mais le souci c'est que la colonne M peut être amenée à bouger, et Excel modifiera tout comme il faut, sauf cette partie:

Code:
"'Tous projets'!M"
puisqu'elle est entre guillemets... mais je n'arrive pas à faire autrement. En gros la formule ne fonctionne plus si la colonne M bouge.

Merci d'avance pour votre aide :)
 

tototiti2008

XLDnaute Barbatruc
Re : Optimisation de formule avec SOMMEPROD et SOUS.TOTAL

Bonjour djodjodjo,

Oui, c'est l'inconvénient et l'avantage (selon les cas) de la fonction INDIRECT (et du texte interprété)

peut-être remplacer

Code:
"'Tous projets'!M"

par

Code:
"'Tous projets'!"&STXT(ADRESSE(1;COLONNE(M1);2);1;CHERCHE("$";ADRESSE(1;COLONNE(M1);2))-1)
 

Discussions similaires

Statistiques des forums

Discussions
298 015
Messages
1 965 154
Membres
200 865
dernier inscrit
lylia654