Autres offixe 2003 excel

edsinouhe

XLDnaute Nouveau
Bonjour,

Comment faire pour résoudre le problème suivant dans mon tableau :

- 1 colonne de date
- 4 colonnes de nombres
- 1 colonne de cumul

Le but est de tester le contenu d'une cellule dans la colonne de date
- si la cellule est renseignée, ne rien faire
- si la cellule est vide ou à blanc, mettre à blanc les 4 cellules de nombres situées sur la même ligne, quels que soit le contenu renseigné ou non

la formule dans la colonne de cumul fonctionne, la mise à jour a bien lieu

Merci de votre aide
 

Yoyo01000

XLDnaute Occasionnel
Bonjour,
méthode la plus simple, pour moi : une MFC
MFC.jpg
 

GALOUGALOU

XLDnaute Accro
re edsinouhe bonsoir le fil bonsoir le forum

VB:
mettre à blanc les 4 cellules de nombres situées sur la même ligne
pourriez-vous préciser ce que vous sous entendez par mettre à blanc
l'écriture en couleur blanche ?
l'effacement des cellules ?
cordialement
galougalou
 

edsinouhe

XLDnaute Nouveau
re edsinouhe bonsoir le fil bonsoir le forum

VB:
mettre à blanc les 4 cellules de nombres situées sur la même ligne
pourriez-vous préciser ce que vous sous entendez par mettre à blanc
l'écriture en couleur blanche ?
l'effacement des cellules ?
cordialement
galougalou

mettre à blanc = effacement des cellules

dans la cellule suivant la cellule de cumuls, j'essai d'appliquer cette fonction
=SI(SUPPRESPACE(CTXT(LC(-6)))="";LC(-5):LC(-1)="";)
mais rien ne se passe pour l'effacement des cellules contenant les nombres
 

edsinouhe

XLDnaute Nouveau
mettre à blanc = effacement des cellules

dans la cellule suivant la cellule de cumuls, j’essaie d'appliquer cette fonction
=SI(SUPPRESPACE(CTXT(LC(-6)))="";LC(-5):LC(-1)="";)
mais rien ne se passe pour l'effacement des cellules contenant les nombres
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

pour "effacer" les colonnes B, C, D et E si la date en A n'est pas renseignée et garder le cumul en F, il faut passer par VBA.
Désolé je ne sais pas faire mais patience, les pros vont se mettre à l'oeuvre.

Le mieux serait de joindre un fichier exemple avec quelques lignes.

JHA
 

edsinouhe

XLDnaute Nouveau
Bonjour à tous,

pour "effacer" les colonnes B, C, D et E si la date en A n'est pas renseignée et garder le cumul en F, il faut passer par VBA.
Désolé je ne sais pas faire mais patience, les pros vont se mettre à l'oeuvre.

Le mieux serait de joindre un fichier exemple avec quelques lignes.

JHA

Pas de problème avec le cumul, si les zones B C D E sont vides le cumul disparait sur cette cellule
avec la formule suivante

=SI(LC(-5)<>"";((LC(-3)+LC(-1))-(LC(-2)+LC(-4))+INDEX(L4C:L(-1)C;EQUIV(0;L4C:L(-1)C;-1);1));"")

dans le cas contraire, lors de l'ajout d'une nouvelle ligne, le cumul reprend la dernière valeur de cumul située auparavent, quelle que soit l'emplacement de la nouvelle ligne.
 

edsinouhe

XLDnaute Nouveau
Bon, un bon dessin vaut mieux qu'un long discourt...
Je joints le fichier xls en question.

Si on "delete" avec la touche "suppr" au clavier, la date en ligne 12, les valeurs situées dans les 4 colonnes suivantes doivent être effacées. La cellule solde disparait automatiquement.

Dans ce tableau on peut ajouter des données sur n'importe quelle ligne, le solde se met à jour automatiquement.

Si l'on saisi des données sur la dernière ligne (55), alors le tableau de droite est activé avec le report des données de fin du tableau 1.

J'en reviens donc sur la fonction dans la cellule L12C8 qui ne fonctionne pas...

Merci de votre aide.
 

Pièces jointes

  • compte.xls
    45 KB · Affichages: 3

job75

XLDnaute Barbatruc
Voyez le fichier joint et la formule en F4 à copier vers le bas :
Code:
=SI(A4="";"";SOMMEPROD((A$4:A4<>"")*(C$4:C4+E$4:E4-B$4:B4-D$4:D4)))
Il n'y a pas besoin de VBA, comme l'a suggéré Yoyo01000 les valeurs en colonnes B C D E sont masquées par MFC si l'on efface les dates, la formule de la MFC sur B4:E55 est très simple =ESTVIDE($A4).

J'ai aussi modifié les formules en ligne 56.
 

Pièces jointes

  • compte(1).xls
    57.5 KB · Affichages: 8

edsinouhe

XLDnaute Nouveau
Merci de cet exemple. Il me reste à connaître cet MFC dont il est question.
De plus je ne vois pas la fonction =ESTVIDE(...) dans excel 2003.
Idem pour la référence SOMMEPROD(...)

Par ailleurs, un problème au téléchargement, un virus s'est introduit chez moi... je n'en connais pas l'origine...
 

Statistiques des forums

Discussions
290 716
Messages
1 909 852
Membres
176 453
dernier inscrit
Nollan97
Haut Bas