Occulter valeur négative

annov

XLDnaute Occasionnel
Bonsoir,

J'ai un petit problème de valeur négative . Je reporte des valeurs de plusieurs feuilles sur un tableau pour compiler les données => extraction qui me sert à éditer des graphiques , mais si une valeur est négative bien évidemment celà fausse le graphique, j'ai regardé du coté des mise en forme xls et sur le forum et je n'ai rien trouvé ? L'idéal serait d'ignorer le - ou de convertir la valeur à 0 . Mais là je sèche..

Avez vous des pistes sur le sujet ?

Cordialement;
 

job75

XLDnaute Barbatruc
Re : Occulter valeur négative

Bonjour annov,

Le plus simple est de supprimer les valeurs négatives non ?

Sélectionner la plage concernée.

Touches Ctrl+H => Rechercher : -* => Remplacer par : <rien> => Remplacer tout

A+
 

13GIBE59

XLDnaute Accro
Re : Occulter valeur négative

Bonjour annov, job.

Maintenant si tu ne veux pas supprimer les valeurs négatives, tu crées une colonne supplémentaire et tu inscris la formule :

Code:
=SI(B1>0;B1;"")
si tes données sont dans la colonne B, et tu tires vers le bas.
 

job75

XLDnaute Barbatruc
Re : Occulter valeur négative

Bonsoir Jean-Bernard,

Attention, pour un graphique (en nuage de points) des cellules contenant le texte "" ne sont pas vides...

Si les cellules sont vides, sélectionnez le graphique puis menu Outils => Options => Graphique et choisissez Interpolées.

Les cellules vides sont alors ignorées.

Si les cellules contiennent "", le graphique considère que ce sont des valeurs 0...

A+
 
Dernière édition:

annov

XLDnaute Occasionnel
Re : Occulter valeur négative

Bonsoir,

J'essaye depuis tout à l'heure mais il me met "0" partout sauf dans les cellules qui m'interresse?
Pourtant ça devrait marcher ...
 

annov

XLDnaute Occasionnel
Re : Occulter valeur négative

Bonsoir,

Pour moi c'est un graphique barre , J'ai vraiment éssayé pas mal de chose mais alors là ?
je colle..

Cdlt
 

Tibo

XLDnaute Barbatruc
Re : Occulter valeur négative

Bonjour,

Pas sûr que je puisse t'aider, car les graphiques, c'est pas trop mon truc.

Mais si tu nous joignais un petit bout de fichier exemple en nous montrant ce qui ne va pas, peut-être le Forum te trouvera alors une solution

A te (re)lire

@+
 

annov

XLDnaute Occasionnel
Re : Occulter valeur négative

Bonsoir,
Le fichier est un peu trop gros pour le joindre malheureusement.

Je regarde si j'arrive à le rendre un peu plus light mais j'en doute.

Cdlt;
 

Tibo

XLDnaute Barbatruc
Re : Occulter valeur négative

re,

L'important n'est pas joindre ton fichier complet, mais de reproduire le souci sur un fichier exemple.

Et là, si de plus tu zippes ton fichier, il doit passer sans souci

@+
 

eriiiic

XLDnaute Barbatruc
Re : Occulter valeur négative

Bonsoir tout le monde,

Si des #N/A dans le tableau ne te genent pas tu peux mettre en E5 :
=SI(E5="";NA();E5-E3)
(ou équivalent...)

eric
 

job75

XLDnaute Barbatruc
Re : Occulter valeur négative

Re, salut eriiiic,

Sinon, si l'on cherche juste à voir et/ou imprimer une feuille graphique correcte, on peut :

- clic droit sur un onglet => Sélectionner toutes les feuilles

- clic en haut à gauche pour sélectionner toutes les cellules

- clic droit => Copier, clic droit => Collage spécial/Valeurs (les formules sont supprimées)

- touches Ctrl+H et remplacer -* par <rien> comme déjà indiqué, pour les valeurs négatives.

C'est hyper rapide, il n'y a rien à modifier dans les feuilles.

Bien sûr on fermera le fichier sans l'enregistrer :rolleyes:

A+
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas