Obtenir la plus grande valeur entre 2 formules[resolu]

Etn

XLDnaute Occasionnel
Bonjour le forum,

Je souhaiterais obtenir la plus grande valeur entre 2 formules, en évitant de passer par SI.
Actuellement j'ai :

=SI(SOMME.SI.ENS(C1:C10;A1:A10;"a";B1:B10;1)>SOMME.SI.ENS(C1:C10;A1:A10;"a";B1:B10;2);SOMME.SI.ENS(C1:C10;A1:A10;"a";B1:B10;1);SOMME.SI.ENS(C1:C10;A1:A10;"a";B1:B10;2))

Sachant que dans mon fichier j'ai plus de conditions et plus longues. N'y a t-il pas un moyen de ne pas répéter chaque formule 2 fois ? Je souhaite juste récupérer le résultat le plus élevé (sans passer par des cellules intermédiaires)

Merci de votre aide,

Etn
 

Fichiers joints

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Etn,

Peut etre de cette façon

VB:
=MAX(SOMME.SI.ENS(C1:C10;A1:A10;"a";B1:B10;2);SOMME.SI.ENS(C1:C10;A1:A10;"a";B1:B10;1))
Cordialement
 
  • J'aime
Reactions: Etn

Etn

XLDnaute Occasionnel
Tout simplement...Honte à moi de ne pas avoir réussi à y penser.
Merci Jocelyn !
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas