XL 2016 numéro semaine

sebastaupole

XLDnaute Nouveau
Bonjour,


Ah mais c'est là-dessus que je suis parti moi

sebastaupole, tu veux dire que la semaine 1 n'existe pas ? Jamais ?
Je trouve cela particulièrement étrange.
Que dois-tu avoir pour le 31/12/18, le 01/01/19, le 04/01/19,puis le 31/12/19 et le 01/01/20 ?
eric
En faite dans ma textbox au lieu qu'il y ai 1 il y a 53 après la 2eme semaine est bien 2
donc pour le 31/12 j'ai 52 et pour le 01/01 j'ai 53 et pour le 01/02 j'ai 2, sur mon fichier LOTUS c'est ainsi bien sur ce fichier est obsolète aujourd'hui et je n'arrive pas a récupérer les codes, il est sur un serveur et c'est compliqué
 

eriiiic

XLDnaute Barbatruc
Je te demande pour 5 dates, tu en fournis 3 dont 1 non demandée, et sans préciser l'année...
Et bien mettre ce que tu veux avoir, pas ce que tu as.

Si tu as vraiment 3 semaines différentes pour 3 jours consécutifs ça n'a pas grand sens.
 

sebastaupole

XLDnaute Nouveau
pour 31/12/18 je veux S 52 / pour 01/01/19 je veux S 01 / pour 07/01/19 je veux S 02 / le 31/12/19 je veux S 52 / 01/01/20 je veux S 01
je m'aperçois en n'écrivant que c'est peut être compliqué comme la dernière semaine de l'année est forcément coupé
est il possible d'avoir une formule sous condition si par exemple en A1 j'ai la formule qui me donne le n° semaine en cours disons 49 et en A2 une formule sous condition qui dit que si A1 est = 52 alors A2 = 1 sinon le resultat de A1 + 1 ce qui donnerai 50 je sais pas si je suis clair !!
 
Dernière édition:

Modeste geedee

XLDnaute Barbatruc
Bonsour®
pour 31/12/18 je veux S 52 / pour 01/01/19 je veux S 01 / pour 07/01/19 je veux S 02 / le 31/12/19 je veux S 52 / 01/01/20 je veux S 01
je m'aperçois en n'écrivant que c'est peut être compliqué comme la dernière semaine de l'année est forcément coupé
Je veux !!!!
:mad::mad:
dans aucun système le mardi 31/12/2019 n'est en : S 52 !!!
1575289887267.png

:mad: révisionnisme !!!
au pire :
=SI(NO.SEMAINE(ladate)=53;52;NO.SEMAINE(ladate))

voir l'aide en ligne (F1) pour NO.SEMAINE


o_O
N° semaine ISO d'une date :
=ENT(MOD(ENT((UneDate-2)/7)+0,6;52+5/28))+1

format de cellule :
"S "00
pour S+1
=ENT(MOD(ENT(((UneDate+7)-2)/7)+0,6;52+5/28))+1
pour S+2
=ENT(MOD(ENT(((UneDate+14)-2)/7)+0,6;52+5/28))+1
pour S+3
=ENT(MOD(ENT(((UneDate+21)-2)/7)+0,6;52+5/28))+1
etc ...
 

sebastaupole

XLDnaute Nouveau
Bonsour®
Je veux !!!!
:mad::mad:
dans aucun système le mardi 31/12/2019 n'est en : S 52 !!!
Voir la pièce jointe 1047778

:mad: révisionnisme !!!
au pire :
=SI(NO.SEMAINE(ladate)=53;52;NO.SEMAINE(ladate))

voir l'aide en ligne (F1) pour NO.SEMAINE


o_O
N° semaine ISO d'une date :
=ENT(MOD(ENT((UneDate-2)/7)+0,6;52+5/28))+1

format de cellule :
"S "00
pour S+1
=ENT(MOD(ENT(((UneDate+7)-2)/7)+0,6;52+5/28))+1
pour S+2
=ENT(MOD(ENT(((UneDate+14)-2)/7)+0,6;52+5/28))+1
pour S+3
=ENT(MOD(ENT(((UneDate+21)-2)/7)+0,6;52+5/28))+1
etc ...
eh tu ma dit mais ce que tu veux alors j'ai mis je veux y a rien de méchant ou d'ordre je n'ai pas exiger quoi que ce soit mais MERCI beaucoup !!! mais oui la 52 eme semaine est toujours a cheval
 

eriiiic

XLDnaute Barbatruc
Tu te mélanges entre Modeste et moi...
Mais pourquoi veux-tu ton propre système de numérotation des semaines qui aura forcément des failles (je sens arriver des semaines à plus de 7j et d'autres à moins de 7j), plutôt que d'utiliser le système ISO ?
Le seul reconnu en europe, et celui que tu retrouves sur le calendrier.
eric
 

sebastaupole

XLDnaute Nouveau
Tu te mélanges entre Modeste et moi...
Mais pourquoi veux-tu ton propre système de numérotation des semaines qui aura forcément des failles (je sens arriver des semaines à plus de 7j et d'autres à moins de 7j), plutôt que d'utiliser le système ISO ?
Le seul reconnu en europe, et celui que tu retrouves sur le calendrier.
eric
oui désolé je me suis mélangé en faite je connaissais déja la formule de modeste et du coup je part avec celle ci je pense que ça le ferra merci a tous
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas