Non reconnaissance des lettres dans recherchev

saella

XLDnaute Nouveau
Bonjour,

J'ai un petit problème avec un tableau que j'essaie de faire dans excel.

Je suis dans le système américain et j'aimerais créer un tableau permettant de calculer la moyenne globale d'un élève selon sa note. Le souci, c'est que les notes sont indiquées sous forme de chiffres : A, A-, B+...

Selon le type de cours suivi par l'élève, chaque note vaut un certain nombre. Ensuite, on fait une moyenne de ces nombres pour trouver la moyenne globale.

J'ai donc fait un premier tableau avec les lettres et les nombres correspondants, puis un tableau où il suffit d'entrer la lettre pour qu'excel aille, avec recherchev, chercher le nombre correspondant.
Et c'est là que ça bug...
Excel retrouve bien certains nombres, mais pour d'autres (comme B ou B-), il renvoie à une lettre plus haut (A-). Pourquoi, et comment contourner cela ?

Je vous joins ma feuille excel pour que ce soit plus clair. Le tableau tout à droite en vert montre les lettres qui fonctionnent et celles où le système plante.

Merci beaucoup,
Sophie
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Re : Non reconnaissance des lettres dans recherchev

Bonjour et Bienvenue sur XLD,
il te faut le 4ème argument de la RECHERCHEV()
=RECHERCHEV(A3;$G$2:$I$13;2;0)


@ + +
 

Discussions similaires


Haut Bas