nommer une plage de cellules dans une fonction rechercheV

A

Albert MARINI

Guest
Bonjour à tous !
Je travaille sur 3 tableaux qui correspondent chacun à un client (Client A, B, C). Chaque tableau est sur une feuille differente, le tableau d'un client comporte 2 colonnes, la première indique le port de départ et la seconde le prix de transport. Je voudrais pouvoir faire des recherches à partir d'une seule formule recherchev sur les 3 tableaux, j'ai attribué à chaque tableau un nom faisant réference à une plage de cellules (table matrice). Afin de ne pas modifier ma formule unique en fonction du client, je voudrais qu'en tapant le nom de la page de cellule dans une cellule indépendante, la formule comprenne qu'elle doit chercher dans un des 3 tableau par rapport au nom de la plage de cellule.
Ex: je tape dans une cellule independante C1 "A" (nom de la plage de cellules du tableau du client A), pour que la formule comprenne =RECHERCHEV(valeur_cherchée;C1 (soit A, B ou C);n° index colonne) cependant la formule indique à chaque fois #N/A.

Merci d'avance pour votre aide !
Sincères salutations
 

Fichiers joints

J

Jean-Marie

Guest
Bonjour Albert

Albert supprime ce que je t'ai envoyé. Mais je suis parti dans un délire, mais dans un délire ....


Dans la cellule C9 de ton exemple, tape cette formule.

=RECHERCHEV(B9;SI(D1="A";'Clt A'!A1:B6;SI(D1="B";'Clt B'!A1:B6;'Clt C'!A1:B6));2)

Quand j'avais testé, le contenu de la cellule était une erreur. Bon bref !

Petite remarque dans la cellule A9, tu dois indiquer un code viable, sinon #NA s'affiche.

Bonne journée.

@+Jean-Marie
 

Discussions similaires


Haut Bas