Nombre de matricules sans doublons si critère

Vilain

XLDnaute Accro
Bonjour à tous,

J'ai aujourd'hui un souci que j'ai l'impression d'avoir déjà réglé 1000 fois mais qui me pose problème aujourd'hui.
J'ai en colonne A des matricules (avec doublons). En colonne B, le pays.
Je souhaite trouver une formule qui me permet de savoir le nb de matricules différents par pays.
Je joins mon fichier pour plus de clarté.

A plus et merci d'avance
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Re : Nombre de matricules sans doublons si critère

Bonjour Gillus,
en E2,
Code:
=NB(1/FREQUENCE(SI($B2:$B32=E1;EQUIV($A2:$A32;$A2:$A32;0));LIGNE(INDIRECT("1:"&LIGNES(A2:A32)))))
@ valider par Ctrl+Maj+Entree
@ tirer vers la droite
@ micalement
 

Vilain

XLDnaute Accro
Re : Nombre de matricules sans doublons si critère

Salut Rachid,
Je me doutais que la réponse viendrait de toi.
Non, en fait, je n'avais surement jamais fait ça, la formule de me dit rien....
Je regarde ça avec attention.

Merci beaucoup :)
 

R@chid

XLDnaute Barbatruc
Re : Nombre de matricules sans doublons si critère

Bonjour Gillus,
la formule de me dit rien....
J'ai pas bien compris que tu sais comment suis-je avec le français???
elle me renvoie 8 et 5
@ te lire
 

Vilain

XLDnaute Accro
Re : Nombre de matricules sans doublons si critère

Re,

Faute de frappe : "la formule ne me dit rien"
Ton français est excellent et tu le sais déjà ;)

A plus
 

Vilain

XLDnaute Accro
Re : Nombre de matricules sans doublons si critère

Cela marche parfaitement mais je ne parviens pas à la décrypter.
Tu peux me l'expliquer ?

Merci d'avance
 

R@chid

XLDnaute Barbatruc
Re : Nombre de matricules sans doublons si critère

Bonjour Gillus,
Tu peux voir sur l'audit de formule il vas te dire plein de chose...
Amicalement
 

R@chid

XLDnaute Barbatruc
Re : Nombre de matricules sans doublons si critère

Bonjour Gillus,
une formule d'un prof,
Sélectionner la plage E1:F1, coller cette formule dans la barre des formules,
Code:
=TRANSPOSE(FREQUENCE(SI(FREQUENCE(A2:A32;A2:A32);EQUIV(B2:B32;E1:F1;0));{1;2}))
@ valider toujours par Ctrl+Maj+Entree
@ micalement
 

JHA

XLDnaute Barbatruc
Re : Nombre de matricules sans doublons si critère

Bonjour à tous,

Juste deux autres "matricielle" pour le fun

Code:
=SOMME((FREQUENCE(SI($B$1:$B$38=E$1;EQUIV($A$1:$A$38;$A$1:$A$38;0));LIGNE($A$1:$A$38))>0)*1)
Code:
=SOMME(SI(($B$2:$B$38=E$1);N(FREQUENCE($A$2:$A$38;$A$2:$A$38)>0)))
JHA
 
Dernière édition:

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas