nbre de mois de 31 jours complets entre 2 dates

LPandre

XLDnaute Impliqué
Bonjour à toutes / tous.

je souhaite une formule qui me remonte le nombre de mois de 31 jours complets entre 2 dates(saisies dans 2 cellules différentes).

exemple : du 2 /01/2016 au 30/05/2016, il n' y a qu'1 mois de 31 jours complet (mars), du 01/01/2016 au 31/05/2016, il y en a 3 ( janvier, mars et mai).

Et bien sur du 01/07/2016 au 31/08/2016, il y en a 2 !

Par avance MERCI.
 

LPandre

XLDnaute Impliqué
Re : nbre de mois de 31 jours complets entre 2 dates

@JBARBE : merci.
ça ne fonctionne pas tout le temps. J'ai incrémenté ta formule avec d'autres dates et "ça coince" (voir fichier joint, lignes 4 à 6)
 

Pièces jointes

  • Nb_Moisv2.xls
    38 KB · Affichages: 34

LPandre

XLDnaute Impliqué
Re : nbre de mois de 31 jours complets entre 2 dates

@JBARBE : uniquement les mois de 31 jours complets !! juin, septembre, novembre, n'ont pas 31 jours.

et en ligne 5, ni mai 2016, ni janvier 2017 ne sont à prendre en compte car la date pour mai commence le 02 (donc non complet), et la date pour janvier 2017 s’arrête le 30, donc non complet.
 
Dernière édition:

GerardCalc

XLDnaute Occasionnel
Re : nbre de mois de 31 jours complets entre 2 dates

Bonjour,

Sur le premier exemple, j'ai 3 (janvier, mars, mai).
Sinon :

Code:
=SOMMEPROD(--(JOUR(LIGNE(INDIRECT(A2&":"&B2)))=31))-ET(JOUR(A2)>1;JOUR(FIN.MOIS(A2;0))=31)
A+
 
Dernière modification par un modérateur:

Discussions similaires

Réponses
11
Affichages
722
Haut Bas