NB.SI.ENS : Si les colonnes E,F,G sont vides, alors compter le nombre de valeur en D.

LeRevenant

XLDnaute Occasionnel
Salut les pros d'excel,

Tout est dans le titre, mais bon j'explique vite fait:
-Vous avez des des en D
-Vous avez des "trucs" en E,F,G

Le but c'est de compter le nombre de valeurs en D qui n'ont rien en E en F et en G.

Dans ma PJ, le 1er onglet (nb.si.ens à faire) c'est là qu'il faudrait mettre la formule sans ajouter de colonne s'il vous plaît :)
Dans le deuxième onglet (Ma méthode bricolage), je l'ai fait, mais en ajoutant une colonne :/

Encore merci et à bientôt :) :D
 

Fichiers joints

R@chid

XLDnaute Barbatruc
Re : NB.SI.ENS : Si les colonnes E,F,G sont vides, alors compter le nombre de valeur

Bonjour,
si j'ai bien saisi ta demande :
Code:
=SOMMEPROD((D5:D9<>"")*(NB.SI(DECALER(E4;LIGNE(INDIRECT("1:"&LIGNES(D5:D9)));;;3);"*")=0))


@ + +
 

LeRevenant

XLDnaute Occasionnel
Re : NB.SI.ENS : Si les colonnes E,F,G sont vides, alors compter le nombre de valeur

salut,

Merci de ton aide, tu gères ;)
Par contre sommeprod c'est pas la fonction qui fait ramer le fichier excel?

Enfin bref, merci :)
 

gosselien

XLDnaute Barbatruc
Re : NB.SI.ENS : Si les colonnes E,F,G sont vides, alors compter le nombre de valeur

Bonjour;

AMHA, toutes les matricielles sont gourmandes en ressources :)

P.
 

LeRevenant

XLDnaute Occasionnel
Re : NB.SI.ENS : Si les colonnes E,F,G sont vides, alors compter le nombre de valeur

Yo,

Alors j'ai trouvé mieux ;)

Code:
=NB.SI.ENS(I7:I25;"<=28/02/2017";J7:J25;"=";K7:K25;"=";L7:L25;"=")
où : I7:I25 c'est la plage de données où voulez effectuer le NB.SI
et il ne faut pas que J, K, L soient vides.
Ah, en plus ça prend que les valeurs avant le 28 février 2017 (j'avais pas osé le demander pour le moment)

Donc, je suis content :cool:
 

Créez un compte ou connectez vous pour répondre

Vous devez être membre afin de pouvoir répondre ici

Créer un compte

Créez un compte Excel Downloads. C'est simple!

Connexion

Vous avez déjà un compte? Connectez vous ici.

Haut Bas