XL 2019 NB SI avec critère en Ligne ET Colonne

Julien_m

XLDnaute Junior
Bonjour le forum :)

Je viens vers vous car je cherche un équivalent à cette formule :
VB:
=SOMMEPROD(($A$5:$A$8=$A16)*($B$4:$Y$4=B$15)*$B$5:$Y$8)
mais pour compter le nombre de cellules non vides dans une plage.
Comme avec la fonction sommeprod qui me convient parfaitement pour avoir la somme avec les critères en ligne et en colonne, je souhaite la même chose avec un équivalent à NB.SI...

J'espère être clair dans ma description.

Merci d'avance 😉

Julien
 

Julien_m

XLDnaute Junior
Bon excusez moi pour mon manque de clarté... Voici qui devrait être mieux avec un exemple.

En bas (sans formules) c'est le résultat souhaité avec une formule équivalente à NB.SI.

De plus j'aimerais si possible savoir comment ajouter un deuxième critère en lignes (avoir année + semaine en critère).
 

Pièces jointes

  • Classeur2.xlsx
    11 KB · Affichages: 7

Discussions similaires

Réponses
9
Affichages
752

Statistiques des forums

Discussions
291 667
Messages
1 916 973
Membres
179 500
dernier inscrit
oximo
Haut Bas