XL 2016 Nb de jour avec une heure inférieur à + 00:45

bigeart

XLDnaute Junior
Supporter XLD
Bonjour à tous,

Je suis bloqué sur une formule additionnant le nb de jour ne dépassant pas une heure maximal.
Mon fichier Excel est au calendrier 1904 et en format TEXTE.
Les heures avec le singe (+) sont les heures en retard
Les heures avec le signe (-) sont les heures en avance.
Je voudrais le nombre de retard inférieur ou égale à + 00:45. (Cellule B41 et K41 en rouge)
C'est là que ça coince, ma formule prend en compte les heures comprises entre 00:00 et + 00:45
mais elle ne prend pas en compte les heures négative.
A priori, il me semble qu'au format TEXTE cela soit bloquant.
Exemple: En B41 la réponse est 9 alors qu'elle devrait être de 19. (10 heures négative plus les 9 heures positives inférieur à + 00:45)
J'espère avoir été assez précis.

En vous remerciant par avance de vos analyses.

Bigeart
 

Pièces jointes

  • SUIVI QUAL 2021.xls
    264.5 KB · Affichages: 11

Victor21

XLDnaute Barbatruc
Bonjour, @bigeart .
Je n'ai pas compris comment vous arrivez à 19. Pouvez-vous surligner les valeurs à prendre en compte ?
Votre formule en B41 peut être simplifiée :
=SOMMEPROD(($R$5:$R$35=MOIS(1&$A4))*(($S$5:$S$35)>0)*(($S$5:$S$35)<45/1440))
Edit : sans validation matricielle
 

bigeart

XLDnaute Junior
Supporter XLD
Bonjour, @bigeart .
Je n'ai pas compris comment vous arrivez à 19. Pouvez-vous surligner les valeurs à prendre en compte ?
Votre formule en B41 peut être simplifiée :
=SOMMEPROD(($R$5:$R$35=MOIS(1&$A4))*(($S$5:$S$35)>0)*(($S$5:$S$35)<45/1440))
Edit : sans validation matricielle
Bonsoir Victor21,

Je te remercie pour ce retour.
Les valeurs à prendre en compte sont toutes les valeurs négatives et les valeurs positives allant jusqu'à + 00:45
 

Victor21

XLDnaute Barbatruc
Bonjour, @bigeart
Dans le fichier joint, les formules des colonnes D, G et N ont été simplifiées.
Les formules en B41:B45 également. (Les autres tableaux n'ont pas été touchés)
Les calculs intermédiaires dans les colonnes RSTU ne sont plus utilisés, et j'ai revu et simplifié les mises en forme conditionnelles de A5:Q35.
Certaines valeurs en colonnes B et E ont été modifiées aux fins de tests.
 

Pièces jointes

  • Copie de SUIVI QUAL 2021.xls
    265 KB · Affichages: 2

bigeart

XLDnaute Junior
Supporter XLD
Bonjour Victor21,

Effectivement, il y a une grande simplification sur les formules. Ce qui est cohérent dans le résultat et je te remercie grandement. Il est parfois bon de rester sur des approches plus simple.
Cette modif de formule m'a fait sauter le temps moyen de la cellule G37.
Puis-je te solliciter afin d'avoir la moyenne de la colonne G en exclueant les WE et Jour fériés.

Encore merci pour ton travail

Cordialement.

Bigeart
 

Statistiques des forums

Discussions
297 960
Messages
1 964 647
Membres
200 628
dernier inscrit
pop600