#NA sur Format TEXTE

alb05

XLDnaute Occasionnel
bonjour
je ne comprends pas pourquoi la fonction INDEX me renvoie un #NA sur l'exemple ci joint.
C'est un pb de format TEXTE, malgré qu'il soit identique entre la colonne H et A.
La colonne A est issue d'un fichier .TXT ouvert et convertit en XLS.
Avez vous, svp, une idée comment résoudre cette erreur en adaptant la formule ?
merci
 

Fichiers joints

G

Guest

Guest
Re : #NA sur Format TEXTE

Bonjour,

Soit tu convertit ta colonne A en nombre ou alors:

Code:
=INDEX($A$2:$D$10;EQUIV(TEXTE($H2;"0000");$A$2:$A$10;0);2)
A+
 
G

Guest

Guest
Re : #NA sur Format TEXTE

Bonjour,

Allons y dans l'autre sens, pas difficile à trouver en réfléchissant un peu:

Code:
=INDEX($A$8:$D$10;EQUIV(H8*1;$A$8:$A$10;0);2)
Ou
Code:
=INDEX($A$8:$D$10;EQUIV(CNUM(H9);$A$8:$A$10;0);2)
A+
 

alb05

XLDnaute Occasionnel
Re : #NA sur Format TEXTE

Merci
J'en déduis donc qu'il fallait convertir en numérique, soit par CNUM, soit par *1; la valeur recherchée.
Ce qui est bizarre et que je ne comprend pas, c'est que la valeur recherchée était du texte, tout comme la valeur cible :
cf FORMAT / CELLULE = Texte
Donc en théorie, excel aurait du trouver sans avoir à convertir dans un sens ou dans un autre;
n'est ce pas ?
 
G

Guest

Guest
Re : #NA sur Format TEXTE

Bonjour,

C'est là ou tu te trompes:
Dans le premier exemple, la valeur recherchée était bien numérique et la plage cible contenait des textes

Dans le deuxième exemple c'est le contraire.

Pour t'en convaincre utilises la formule EstTexte(Cellule) .

A+
 

Tibo

XLDnaute Barbatruc
Re : #NA sur Format TEXTE

Bonjour,

Pour compléter l'explication de Hasco:), je pense que le format Texte a été appliqué après la saisie de tes nombres.

Et cela n'a pas pour effet de leur donner un caractère Texte.

@+
 

alb05

XLDnaute Occasionnel
Re : #NA sur Format TEXTE

A nouveau EXACT.
Mais il y a bien incohérence entre le résultat de EstTexte() et celui de FORMAT/CELLULE !
 

haonv

XLDnaute Occasionnel
Re : #NA sur Format TEXTE

Bonsoir alb05, Hasco,

Il est vrai que dans le premier fichier , les cellules sont toutes au format texte.
Si tu retapes les valeurs dans les cellules colonnes H ,les NA disparaissent.
J'ai fait des essais:
-colonne H au format "standard"
-tu tapes les valeurs
-NA bien sur
-tu passes au format "texte"
-NA toujours
Maintenant on efface les valeurs colonne H
-tu laisses au format "texte"
-tu saisis les valeurs colonne H
pas de problème.

Apparemment il faut que le format des cellules soient identiques AVANT de saisir les valeurs.
Je pense que Hasco va confirmer ou infirmer cela.

Amicalement et merci d'avance ,Hasco

Edit :bonsoir Tibo,je vois que tu as répondu à ma question ...avant même que je ne l'ai posée....
 
Dernière édition:

Discussions similaires


Haut Bas