#na dans résultat avec index

VINCEGR

XLDnaute Occasionnel
bonjour le forum,:)

je vous joins un fichier avec une erreur dans le résultat

le calcul avec index

=+SI(B17<>"";+INDEX(refact;EQUIV($B17;Syndicat;0);EQUIV($C17;année;0);""))


ou est mon erreur ?

merci pour votre aide
 

Fichiers joints

Dernière édition:

kjin

XLDnaute Barbatruc
Re : #na dans résultat avec index

Bonjour,
Code:
=SI($D17<>"";DECALER($E$2;;ANNEE(AUJOURDHUI())-ANNEE($D17));"")
A+
kjin
 

VINCEGR

XLDnaute Occasionnel
Re : #na dans résultat avec index

bonjour kjin,

le code dois avoir comme base c17 et non d17 car je modifie l'année concernée en c17
exemple si
" essai (année) 2009 coeff 0.97 "

est-ce + clair ?

merci pour ton aide
@+
 

Tibo

XLDnaute Barbatruc
Re : #na dans résultat avec index

Bonjour,

Le problème est dans la définition du nom refact

refact ne contient qu'une seule ligne.

Or, avec l'exemple que tu donnes, tu recherches une donnée située sur la 5ème ligne de refact.

Je te laisse regarder plus en détail

@+
 

VINCEGR

XLDnaute Occasionnel
Re : #na dans résultat avec index

bonjour Tibo,

je penses que mon tableau était mal fait donc je l'ai refait pour une meilleur compréhension.
avec les données modifiées.
@+
 

Tibo

XLDnaute Barbatruc
Re : #na dans résultat avec index

re,

Peut-être avec ceci en H17 :

Code:
=SI($D17<>"";DECALER($E$2;EQUIV($B17;$A$3:$A$11;0);ANNEE(AUJOURDHUI())-
ANNEE($D17));"")
Pas trop compris la partie : ANNEE(AUJOURDHUI())-ANNEE($D17)

@+
 

Tibo

XLDnaute Barbatruc
Re : #na dans résultat avec index

re,

Peut-être ceci alors :

Code:
=SI($B17="";"";INDEX($E$3:$M$11;EQUIV($B17;$A$3:$A$11;0);EQUIV($C17;$E$2:$M$2;0)))
@+
 

Discussions similaires


Haut Bas